Board index » delphi » Paradox database on CD don't work without setup

Paradox database on CD don't work without setup

 My software (I used D5) and database (Paradox tables) work well on HD,
even when I set the files to read only. Naturally I set my TDatabase and
TTables to "read only" and "exclusive use". When I put all files
(software & database) on a CDROM, I get an BDE error like "no memory
left on HD".  It seems as if the BDE standard driver uses memory in
directory of the sofware ore database. How can I solve this problem? I
don't like setups, when there is no need.

Martin Rhinow

 

Re:Paradox database on CD don't work without setup


You're going to have to put a directory lock in each of the data
directories on the CD.

--
Lorrin
"Martin Rhinow (T-Online)" <MartinRhi...@t-online.de> wrote in message
news:395898E5.A16040EA@t-online.de...

Quote
> My software (I used D5) and database (Paradox tables) work well on
HD,
> even when I set the files to read only. Naturally I set my TDatabase
and
> TTables to "read only" and "exclusive use". When I put all files
> (software & database) on a CDROM, I get an BDE error like "no memory
> left on HD".  It seems as if the BDE standard driver uses memory in
> directory of the sofware ore database. How can I solve this problem?
I
> don't like setups, when there is no need.

> Martin Rhinow

Re:Paradox database on CD don't work without setup


See http://community.borland.com/article/0,1410,16333,00.html

--
Bill Todd (TeamB)
(Questions received via email cannot be answered.)

Re:Paradox database on CD don't work without setup


Hi Martin,

look into the Downloads Section (Help Files) of the Delphi Pool at

http://ourworld.compuserve.com/homepages/lmc/dpool.htm

There's a help file called cd.zip, which covers the topic of distributing
Pdox tables on CD in detail.

HTH
Uwe

"Martin Rhinow (T-Online)" <MartinRhi...@t-online.de> schrieb im Newsbeitrag
news:395898E5.A16040EA@t-online.de...

Quote
> My software (I used D5) and database (Paradox tables) work well on HD,
> even when I set the files to read only. Naturally I set my TDatabase and
> TTables to "read only" and "exclusive use". When I put all files
> (software & database) on a CDROM, I get an BDE error like "no memory
> left on HD".  It seems as if the BDE standard driver uses memory in
> directory of the sofware ore database. How can I solve this problem? I
> don't like setups, when there is no need.

> Martin Rhinow

Other Threads