Board index » delphi » "Leaking Paradox Database"

"Leaking Paradox Database"

Dear All,

I am having a problem inserting a record into a Paradox 7.0 database, using a
programme written in Delphi 3. It used to work fine, until I observed that
the database is "leaking" a few days ago. I am using the Prepare method and
then ExecSQL methods of the TQuery object. When I run the programme with the
table in Paradox open, I see the record appearing. When I exit from Paradox
and open the table again, the record is gone... A query carried out in the
Database Explorer does give a permanent record in the database. Has anybody
experienced the same problem? Please help.

Thanks in advance,
Steven Hoek

-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own    

 

Re:"Leaking Paradox Database"


Quote
h...@virtual-affairs.nl wrote:
> Dear All,

> I am having a problem inserting a record into a Paradox 7.0 database,
> using a programme written in Delphi 3. [snip!]

Then news.comp.lang.pascal.delphi.databases is probably where you want to post
such a query; c.l.p.b is not for Delphi questions, nor is there any common tie
between Paradox and TP.  This response per se probably doesn't answer your
question, but it should put you in the company of those who can.  :-)

Quote
> Thanks in advance,
> Steven Hoek

> -----------== Posted via Deja News, The Discussion Network ==----------
> http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own

--
Scott Earnest            | SPAM protection in effect. Remove  |
setech@_ix.netcom.com    | "_" as needed for true addresses.  |
earnests@_homenet.lm.com |    UIN:1136443  EFnet:pale_blue    |
sinykal@_{*word*104}space.org  | URL: http://www.netcom.com/~setech |

Other Threads