Board index » delphi » Oracle 8i : ORA-01041

Oracle 8i : ORA-01041

Has anyone had a problem connecting to Oracle 8.1.5 with the BDE on a
windows 95 machine? Oracle has a bug where you have to comment out your
sqlnet.authentication_services parameter in your sqlnet.ora file. We've
done that and oracle works fine now but the bde returns an
ORA-01041:Hostdef extension does not exist whenever you try to connect.
Does anyone have any idea about how to fix this? Thanks in advance.

Paul Mercadante
m...@plateausystems.com

 

Re:Oracle 8i : ORA-01041


Re:Oracle 8i : ORA-01041


Hi,
Did you try with BDE 5.1?
I'm able to connect without problems, but sometimes, when closing live
queries or tables I receive an error that the connection is no longer
available. This happens on a customer installation, therefore I can't
specify the exact Oracle message now. All works fine with Oracle 8.0.4.

Anton Santa
SABE SOFT

Quote
Paul Mercadante <m...@plateausystems.com> wrote in message

387A57AF.B03B7...@plateausystems.com...
Quote
> Has anyone had a problem connecting to Oracle 8.1.5 with the BDE on a
> windows 95 machine? Oracle has a bug where you have to comment out your
> sqlnet.authentication_services parameter in your sqlnet.ora file. We've
> done that and oracle works fine now but the bde returns an
> ORA-01041:Hostdef extension does not exist whenever you try to connect.
> Does anyone have any idea about how to fix this? Thanks in advance.

> Paul Mercadante
> m...@plateausystems.com

Re:Oracle 8i : ORA-01041


Re:Oracle 8i : ORA-01041


Please run the BDE administration utility and verify the following entries
in the \Drivers\Native\Oracle\ section:

  DLL32 = SQLORA8.DLL
(Oracle 8 SQL Link)

  VENDOR INIT = D:\orant\BIN\OCI.DLL
(for an Oracle 8.0 client)
  VENDOR INIT = D:\Oracle\Ora81\BIN\ORACLIENT8.DLL     (for an Oracle 8.1
client)

Holger Heidenbluth
KeepTool Software GbR - Tools for Oracle Databases
http://www.keeptool.com

Paul Mercadante <m...@plateausystems.com> schrieb in im Newsbeitrag:
387A57AF.B03B7...@plateausystems.com...

Quote
> Has anyone had a problem connecting to Oracle 8.1.5 with the BDE on a
> windows 95 machine? Oracle has a bug where you have to comment out your
> sqlnet.authentication_services parameter in your sqlnet.ora file. We've
> done that and oracle works fine now but the bde returns an
> ORA-01041:Hostdef extension does not exist whenever you try to connect.
> Does anyone have any idea about how to fix this? Thanks in advance.

> Paul Mercadante
> m...@plateausystems.com

Other Threads