Board index » delphi » Problem: MS SQL Server 7.0 with Delphi 4.02

Problem: MS SQL Server 7.0 with Delphi 4.02

I working with Delphi 4.02, MS SQL Server 7.0 and Native SQL links

I can not execute stored procedure that have some parametrs and one of them
defined as OUTPUT of type char(100).

Thank you.

sl...@ramsoft.co.il

 

Re:Problem: MS SQL Server 7.0 with Delphi 4.02


Quote
slava wrote:

> I working with Delphi 4.02, MS SQL Server 7.0 and Native SQL links

> I can not execute stored procedure that have some parametrs and one of them
> defined as OUTPUT of type char(100).

> Thank you.

> sl...@ramsoft.co.il

Please post the Stored Procedure

Rkr
--

                   \|||/
                   /'^'\
                  ( 0 0 )
--------------oOOO--(_)--OOOo--------------
. Reid Roman                              .
. Delphi Programmer / Analyst             .
. TVisualBasic:=class(None)               .
. May the Source be With You              .
-------------------------------------------
. Auto-By-Tel (http://www.autobytel.com)  .
. Irvine, CA U.S.A                        .
. E-Mail : rkroman (at) home (dot) com    .
-------------------------------------------

Re:Problem: MS SQL Server 7.0 with Delphi 4.02


Are you getting any error. There is a known MS bug in this area may be you are
facing that.

T.Ramesh.

Quote
slava wrote:
> I working with Delphi 4.02, MS SQL Server 7.0 and Native SQL links

> I can not execute stored procedure that have some parametrs and one of them
> defined as OUTPUT of type char(100).

> Thank you.

> sl...@ramsoft.co.il

Re:Problem: MS SQL Server 7.0 with Delphi 4.02


I have a similar problem.
When trying to connect to a storedproc I get an error "object not found" and
the name of the storedproc.

The storedproc returns a resultset and has 1 inputparameter. When I try to
execute the storeproc from a TQuery like Select * from
employee_in_project(1) where the parameter is the project_id I get a General
SQL fault.

I use native MSSQL drivers on BDE 5.01 with the latest drivers.

Are there any new BDE drivers that supports MSSQL 7.0 beta 3 or are I'm
missing something ?

Rgds. Preben

Re:Problem: MS SQL Server 7.0 with Delphi 4.02


Quote
Preben Asmussen wrote:

> I have a similar problem.
> When trying to connect to a storedproc I get an error "object not found" and
> the name of the storedproc.

> The storedproc returns a resultset and has 1 inputparameter. When I try to
> execute the storeproc from a TQuery like Select * from
> employee_in_project(1) where the parameter is the project_id I get a General
> SQL fault.

> I use native MSSQL drivers on BDE 5.01 with the latest drivers.

> Are there any new BDE drivers that supports MSSQL 7.0 beta 3 or are I'm
> missing something ?

Have you tried creating and selecting into a temp table the results of
the embedded stored procedure?

Rkr
--

                   \|||/
                   /'^'\
                  ( 0 0 )
--------------oOOO--(_)--OOOo--------------
. Reid Roman                              .
. Delphi Programmer / Analyst             .
. TVisualBasic:=class(None)               .
. May the Source be With You              .
-------------------------------------------
. Auto-By-Tel (http://www.autobytel.com)  .
. Irvine, CA U.S.A                        .
. E-Mail : rkroman (at) home (dot) com    .
-------------------------------------------

Other Threads