Board index » delphi » Problem #1: 'Call to RegisterClasses'

Problem #1: 'Call to RegisterClasses'

I'm getting the following message: 'Error in module Unit7: Call to
RegisterClasses is missing or incorrect.'  I've examined the code in the
'type' section of Unit7 pretty closely and cannot find any obvious errors.
 Every component on the form that makes up Form7 seems to be listed under
'type'.  Where else should I look for a bug??

Thanks.

John W. Gilmer

 

Re:Problem #1: 'Call to RegisterClasses'


Quote
WarpTwelve wrote:

> I'm getting the following message: 'Error in module Unit7: Call to
> RegisterClasses is missing or incorrect.'  I've examined the code in the
> 'type' section of Unit7 pretty closely and cannot find any obvious errors.
>  Every component on the form that makes up Form7 seems to be listed under
> 'type'.  Where else should I look for a bug??

> Thanks.

> John W. Gilmer

John,

You probably deleted and end; statement from a procedure.

Matthew
--

==================================================================
Matthew McDermott
McDermott Enterprises
matt...@valleynet.com
My Web Page: http://www.valleynet.com/~matthew
------------------------------------------------------------------
Director of Information Services & Adjunct Professor - Mathematics
The American College of Prehospital Medicine: http://www.acpm.edu/
==================================================================

Re:Problem #1: 'Call to RegisterClasses'


Quote
warptwe...@aol.com (WarpTwelve) wrote:
>I'm getting the following message: 'Error in module Unit7: Call to
>RegisterClasses is missing or incorrect.'

I've had this (and even posted a note in one of these newsgroups about it).
Check you haven't deleted the final period from the final "end." in a unit.

-------------
Keith Edmunds
Reading,   UK
-------------

Other Threads