Board index » delphi » Installshield / BDE 5.01 error in D 4.02

Installshield / BDE 5.01 error in D 4.02

It seems that InstallShild Express 2.02 is not compatible with DB 5.0x.
I get this indo's from InstallShield NewsGroups
So or you use the Bde 2.0x or you take a train....
Have good coding.

If you solve the problem please send me a message I have spent one week try to solve this problem....

P.Parenti
    ASchubert ha scritto nel messaggio <36D36115.EE568...@mandic.com.br>...
    I generate in InstallShield Express 2.02 (D C/S 4.02) one Install app for Delphi DataBase application (Paradox Tables with partial BDE).
    The BDE groups and files are:

    BDE / IDAPI
      IDPDX32.DLL
      IDAPI32.DLL
      IDR20009.DLL
      BLW32.DLL
      IDSQL32.DLL
      IDBAT32.DLL
      IDAPINST.DLL
      BDEADMIN.EXE
      BDEADMIN.HLP
      BDEADMIN.CNT

    BDE / IDAPI CNF
      IDAPI.CNF

    BDE / IDAPI Control Panel
      BDEADMIN.CPL

    In the installation process in my client the error message is :
    "Failed in Adding Alias
    The Error Number is 3, iniatilazion Failed"
    When iniatialize the *.exe file the EDBEngine error is $3E06.

    WHAT IS WRONG ?!

    ASchubert

 

Re:Installshield / BDE 5.01 error in D 4.02


Hi ASchubert,
You might want to try posting to another group because on this one we
only deal with Delphi install issues. Some of my quick reccomendations,
however, are to get the latest IS scripts from the
http://www.borland.com/devsupport/delphi/downloads page. Also, try a
full install of the BDE, not a partial install.
Corbin

Quote
ASchubert wrote:

> I generate in InstallShield Express 2.02 (D C/S 4.02) one Install app
> for Delphi DataBase application (Paradox Tables with partial BDE).

> The BDE groups and files are:

> BDE / IDAPI
>   IDPDX32.DLL
>   IDAPI32.DLL
>   IDR20009.DLL
>   BLW32.DLL
>   IDSQL32.DLL
>   IDBAT32.DLL
>   IDAPINST.DLL
>   BDEADMIN.EXE
>   BDEADMIN.HLP
>   BDEADMIN.CNT

> BDE / IDAPI CNF
>   IDAPI.CNF

> BDE / IDAPI Control Panel
>   BDEADMIN.CPL

> In the installation process in my client the error message is :
> "Failed in Adding Alias
> The Error Number is 3, iniatilazion Failed"
> When iniatialize the *.exe file the EDBEngine error is $3E06.

> WHAT IS WRONG ?!

> ASchubert

--
Corbin Dunn
Delphi Developer Support
www.borland.com
(I do not respond to support questions by e-mail)

Re:Installshield / BDE 5.01 error in D 4.02


The "Failed in Adding Alias, Error #3" simply means that the alias
already exists in the BDE Config files and the Installshield program was
unable to add it again.

The EDBEngine Error is probably a result of an alias that points to the
wrong directory.  This would be consistent with your other error.

Installshield has an update to 2.04 from 2.02 that you should obtain
from them.  If you're doing Delphi 4 installs, you should really upgrade
to version 2.11.

Bill

Quote
> I generate in InstallShield Express 2.02 (D C/S 4.02) one Install app
> for Delphi DataBase application (Paradox Tables with partial BDE).

> The BDE groups and files are:

> BDE / IDAPI
>   IDPDX32.DLL
>   IDAPI32.DLL
>   IDR20009.DLL
>   BLW32.DLL
>   IDSQL32.DLL
>   IDBAT32.DLL
>   IDAPINST.DLL
>   BDEADMIN.EXE
>   BDEADMIN.HLP
>   BDEADMIN.CNT

> BDE / IDAPI CNF
>   IDAPI.CNF

> BDE / IDAPI Control Panel
>   BDEADMIN.CPL

> In the installation process in my client the error message is :
> "Failed in Adding Alias
> The Error Number is 3, iniatilazion Failed"
> When iniatialize the *.exe file the EDBEngine error is $3E06.

> WHAT IS WRONG ?!

> ASchubert

Re:Installshield / BDE 5.01 error in D 4.02


On Wed, 24 Feb 1999 21:53:56 -0800, Bill Austin <b...@radio-writer.com>
wrote:

Quote
>Installshield has an update to 2.04 from 2.02 that you should obtain
>from them.  If you're doing Delphi 4 installs, you should really upgrade
>to version 2.11.

The update is for registered customers of the purchasable edition, not the
free edition shipped with Delphi.

Stefan
InstallShield Software Corp.

Re:Installshield / BDE 5.01 error in D 4.02


Quote
> >Installshield has an update to 2.04 from 2.02 that you should obtain
> >from them.  If you're doing Delphi 4 installs, you should really upgrade
> >to version 2.11.

> The update is for registered customers of the purchasable edition, not the
> free edition shipped with Delphi.

Really can't I get *minor* updates for InstallShield Express?
I'm a happy Delphi programmer. Please, Borland/Inprise, don't disappoint me.
Please let me know if I got it wrong.

---
Diego Regio

Re:Installshield / BDE 5.01 error in D 4.02


Quote
> >Installshield has an update to 2.04 from 2.02 that you should obtain
> >from them.  If you're doing Delphi 4 installs, you should really upgrade
> >to version 2.11.

> The update is for registered customers of the purchasable edition, not the
> free edition shipped with Delphi.

Really can't I get *minor* updates for InstallShield Express?
I'm a happy Delphi programmer. Please, Borland/Inprise, don't disappoint me.
Please let me know if I got it wrong.

---
Diego Regio

Re:Installshield / BDE 5.01 error in D 4.02


Quote
> >Installshield has an update to 2.04 from 2.02 that you should obtain
> >from them.  If you're doing Delphi 4 installs, you should really upgrade
> >to version 2.11.

> The update is for registered customers of the purchasable edition, not the
> free edition shipped with Delphi.

Really can't I get *minor* updates for InstallShield Express?
I'm a happy Delphi programmer. Please, Borland/Inprise, don't disappoint me.
Please let me know if I got it wrong.

---
Diego Regio

Re:Installshield / BDE 5.01 error in D 4.02


Diego,

I think you need to talk to Installshield about updates.  Inprise/Borland
supplies the software on the Delphi CD so that you will have a way to distribute
programs.  I don't really know how they handle updates to the version that comes
on the CD.  I bought the full package from Installshield three years ago, and
have just done upgrades as needed.  They gave me a good price on it, back then,
as a Delphi customer.

Bill

Quote
> > >Installshield has an update to 2.04 from 2.02 that you should obtain
> > >from them.  If you're doing Delphi 4 installs, you should really upgrade
> > >to version 2.11.

> > The update is for registered customers of the purchasable edition, not the
> > free edition shipped with Delphi.

> Really can't I get *minor* updates for InstallShield Express?
> I'm a happy Delphi programmer. Please, Borland/Inprise, don't disappoint me.
> Please let me know if I got it wrong.

> ---
> Diego Regio

Re:Installshield / BDE 5.01 error in D 4.02


On Fri, 26 Feb 1999 03:09:23 -0300, Diego Regio <dregio1NOS...@fnmail.com>
wrote:

Quote
>Really can't I get *minor* updates for InstallShield Express?
>I'm a happy Delphi programmer. Please, Borland/Inprise, don't disappoint me.
>Please let me know if I got it wrong.

Hello Diego,

the version shipped with Borland Delphi is a socalled "Custom Edition". It
is a freebie given to you by us to introduce you to an installation utility
which should get you on the road with your application.

If you want maintenance upgrades, you must purchase a copy of InstallShield
Express from us.

With Regards

Stefan
InstallShield Software Corp.

Other Threads