Board index » delphi » MS Access - BIG BIG Problem?

MS Access - BIG BIG Problem?

Hello All,  (Environment: Delphi 5, BDE 5.10, Access 97,Win9x)

We inherited a program that uses AutoInc fields.

If we create a *new* table the autoinc fields correctly increment by 1.

*Existing* tables increment by 4 or apparently random.
(The field _is_ defined as an autoinc of type 'increment' not 'random')

SQL Explorer exhibits the same behaviour. Is this a bug in BDE 5.10?

I'd very much appreciate it if you did not say it is...

Thanks,

    Tom

 

Re:MS Access - BIG BIG Problem?


Remove all of the Default settings for all of the fields in the table and it
should work correctly. My understanding is that this is a DAO bug.

--
Bill

Bill Todd (TeamB)
(TeamB cannot respond to questions received via email)

Re:MS Access - BIG BIG Problem?


Bill,

Thanks for the response, but the 'workaround' does not work...

1. There is *no* default setting for the autonumber fields within Delphi
2. AutoNumber fields do not have a default in Access.

Where does that leave us?

Tom
---------------------------------------------------------------------------------

Quote
"Bill Todd (TeamB)" wrote:
> Remove all of the Default settings for all of the fields in the table and it
> should work correctly. My understanding is that this is a DAO bug.

> --
> Bill

> Bill Todd (TeamB)
> (TeamB cannot respond to questions received via email)

Re:MS Access - BIG BIG Problem?


Sorry. I obviously was not clear. You need to remvoe the defaults for every
field in the table.

--
Bill

Bill Todd (TeamB)
(TeamB cannot respond to questions received via email)

Re:MS Access - BIG BIG Problem?


Bill,

Early indications are that this is indeed a fix.

Many Thanks indeed.

Tom

---------------------------------------------------------------------------

Quote
"Bill Todd (TeamB)" wrote:
> Sorry. I obviously was not clear. You need to remvoe the defaults for every
> field in the table.

> --
> Bill

> Bill Todd (TeamB)
> (TeamB cannot respond to questions received via email)

Re:MS Access - BIG BIG Problem?


Bill,

One final question - where did you come across the information?

We trawled MSDN and MS Newgroups and could not find any reference to it.

Tom
------------------------------------------------------------------------------------------

Quote
"Bill Todd (TeamB)" wrote:
> Sorry. I obviously was not clear. You need to remvoe the defaults for every
> field in the table.

> --
> Bill

> Bill Todd (TeamB)
> (TeamB cannot respond to questions received via email)

Re:MS Access - BIG BIG Problem?


Someone posted the anwer in this newsgroup a long time ago and I saved
it<g>.

--
Bill

Bill Todd (TeamB)
(TeamB cannot respond to questions received via email)

Re:MS Access - BIG BIG Problem?


To find informatio like this, IMHO it is much easier to use DejaNews at
www.deja.com

--

Woody
Black holes are where God divided by zero.

Quote
Tom Conlon <t...@2ls.com> wrote in message news:38438E90.81C2D502@2ls.com...
> Bill,

> One final question - where did you come across the information?

> We trawled MSDN and MS Newgroups and could not find any reference to it.

> Tom
> --------------------------------------------------------------------------
----------------

> "Bill Todd (TeamB)" wrote:

> > Sorry. I obviously was not clear. You need to remvoe the defaults for
every
> > field in the table.

> > --
> > Bill

> > Bill Todd (TeamB)
> > (TeamB cannot respond to questions received via email)

Other Threads