Board index » delphi » Invalid Blob Handle error posting updates to MSSQL table

Invalid Blob Handle error posting updates to MSSQL table

I'm using Delphi 3.0 with MSSQL Server 6.5.  When I use a TQuery with
RequestLive set to True, I get an 'Invalid Blob Handle in Record Buffer'
error when I attempt to post an update.  The dataset contains about 700
records with two Memo fields. I use TDBMemo components on my form.   I have
already increased my 'Blob to Cache' to 128  and the 'Blob size' to 64 in
the BDE but it did not help. We use pentium PC's with 32 Meg of ram running
Windows95.  What should I do?

Thanks for your help.
Gene

 

Re:Invalid Blob Handle error posting updates to MSSQL table


Quote
Gene Miller wrote:

> I'm using Delphi 3.0 with MSSQL Server 6.5.  When I use a TQuery with
> RequestLive set to True, I get an 'Invalid Blob Handle in Record
> Buffer'
> error when I attempt to post an update.  The dataset contains about
> 700
> records with two Memo fields. I use TDBMemo components on my form.   I
> have
> already increased my 'Blob to Cache' to 128  and the 'Blob size' to 64
> in
> the BDE but it did not help. We use pentium PC's with 32 Meg of ram
> running
> Windows95.  What should I do?

> Thanks for your help.
> Gene

Gene,
Did you get this problem resolved?  I'm running into an identical
problem using Sybase SQL Anywhere.  What is the exact machine
configuration that you are seeing problems on?  We have the executable
installed on 3 machines, 2 are giving us the error and one is not.  The
two errant machines are both Intel Pentium 200, on SuperMicro board,
with 32MB RAM.  The working machine is a Gateway, Intel Pentium 100,
also with 32MB RAM.

We are running:
  Delphi 3.02 Professional (all machines)
  BDE 4.0 (one working / 1 non-working)
  BDE 4.51 (other non-working machine)
  Windows 95 (no service packs installed - all machines)

  Accessing Database through ODBC driver.

Good luck!

- Mike

--
==========================================
=  Michael D. Mount                      =
=  National Field Representatives, Inc.  =
=  Claremont, New Hampshire              =
==========================================

Re:Invalid Blob Handle error posting updates to MSSQL table


Gene,

I have found a solution to the "Invalid BLOB Handle in Record Buffer"
problem with SQLA that may also fix yours.

Check your ODBC 32-bit Administrator driver settings.  I found that
checking the "Microsoft Applications (Keys in SQLStatistics)" box
eliminated the Invalid BLOB Handle errors on both machines that were
getting it.  I hadn't noticed previously but the one machine not
receiving the error had the box checked already (we were using it to
test VB5/SQLA and it HAD to be checked then for VB5 to connect).

Let me know if this works.

- Mike

--
==========================================
=  Michael D. Mount                      =
=  National Field Representatives, Inc.  =
=  Claremont, New Hampshire              =
==========================================

Other Threads