Board index » delphi » INPRISE - DAO PERFORMANCE DOWN UNDER 4.02/ BDE 5.01

INPRISE - DAO PERFORMANCE DOWN UNDER 4.02/ BDE 5.01

It just doesn't get any better- under BDE 5.0 I thought DAO performance was
becoming acceptable. I finally managed to install the 4.02/ BDE 501 update
and now the performance is atrocious.

What are you doing to us, Inprise?

 

Re:INPRISE - DAO PERFORMANCE DOWN UNDER 4.02/ BDE 5.01


Pierre,

(I pasted this text from a similar message)

Please try to narrow this down.  I've spoken with R&D, and they're at a loss to
explain this.  Based on what was done with BDE 5.01, you should only be seeing
performance increases, so I'm very interested in finding out what the problem
is.

Quote
>It just doesn't get any better- under BDE 5.0 I thought DAO performance was
>becoming acceptable. I finally managed to install the 4.02/ BDE 501 update
>and now the performance is atrocious.

>What are you doing to us, Inprise?

John Kaster, Enterprise Product Manager
Please post MIDAS-related messages in inprise.public.midas

Re:INPRISE - DAO PERFORMANCE DOWN UNDER 4.02/ BDE 5.01


Quote
John Kaster wrote in message <36390c90.12511...@forums.inprise.com>...
>Pierre,

>(I pasted this text from a similar message)

>Please try to narrow this down.  I've spoken with R&D, and they're at a
loss to
>explain this.  Based on what was done with BDE 5.01, you should only be
seeing
>performance increases, so I'm very interested in finding out what the
problem
>is.

>>It just doesn't get any better- under BDE 5.0 I thought DAO performance
was
>>becoming acceptable. I finally managed to install the 4.02/ BDE 501 update
>>and now the performance is atrocious.

>>What are you doing to us, Inprise?

>John Kaster, Enterprise Product Manager
>Please post MIDAS-related messages in inprise.public.midas

Hi,
Simply put, Prior to BDE 5.0, opening a large and complex  Access Database
took forever, even with persistent fields. My testing showed that a
comparable ACCESS or VB application would 'knock the socks' off a Delphi
app.

When BDE5 came along I was pleased to see that this aspect of performance
had improved substantially. Indeed, now performance was comparable, if not
better, to VB6.

When I finally got D4.02/ BDE 5.01 installed, the performance degradation
was immediately obvious - when the database is opened performance is as bad
or worse than what it was under  BDE4.xxx.

Once up and running it doesn't seem too bad, so whatever is happening is
happening when the database and tables are being opened.

I tried the suggestion posted in another thread -

Quote
>Changing back to the previous IDDA3532.DLL (5.0.0.38 (0)) corrects the
speed
>problem that we have discovered with IDDA3532.DLL (5.0.1.22 (0))....Now
this
>is probably a tad dodgy and not recommended for commercial release, but it
>goes someway to prove the problem.

but was unable to confirm any improvement.

Pierre

Re:INPRISE - DAO PERFORMANCE DOWN UNDER 4.02/ BDE 5.01


If regressing to the previous version of the DLL didn't help, please try to get
me a test case ASAP.  I think the engineer may have a window to work on the
problem this week.  (Not promising anything, though!)

Quote

>I tried the suggestion posted in another thread -

>>Changing back to the previous IDDA3532.DLL (5.0.0.38 (0)) corrects the
>speed
>>problem that we have discovered with IDDA3532.DLL (5.0.1.22 (0))....Now
>this
>>is probably a tad dodgy and not recommended for commercial release, but it
>>goes someway to prove the problem.

>but was unable to confirm any improvement.

>Pierre

John Kaster, Enterprise Product Manager
Please post MIDAS-related messages in inprise.public.midas

Re:INPRISE - DAO PERFORMANCE DOWN UNDER 4.02/ BDE 5.01


Try using the idao32.dll version 5.0.1.22, not the ida3532.dll.

  eric.giguere.vcf
< 1K Download

Other Threads