Board index » delphi » DBRichEdit doesn't show Text-field in MSSQL6.5

DBRichEdit doesn't show Text-field in MSSQL6.5

I have added Text-field to one of my tables with the purpose of storing
RTF-data in that field. I try to use DBRichEdit to represent that field but
without success. I can load to DBRichEdit external rtf and it is visible
until I apply updates to table - then it disappears. But I can see using SQL
Explorer that value of that field has been stored successfully. Again I open
the form containing DBRichEdit - it suddenly seems empty...
 

Re:DBRichEdit doesn't show Text-field in MSSQL6.5


    Smth. obscure is happening with Subj. I had a table with a Text-field,
everything was OK. I used DBMemo to represent value of that field. Then I've
added one more Text-field - woe is me! I could see in client that field is
always empty (though really it wasn't empty - I used SQL Explorer to check
this). What have I done a few minutes ago? I've just rearranged fields order
using Fields Editor for my TTable in AppServer. I've lifted up that last
added Text-field there and now I can see in DBRichEdit on client side my RTF
in all one's glory BUT !!!... Now the first Text-field (in DBMemo) is empty
for some of records (not for all !!!) where it really wasn't empty before.
What is wrong with me?
    I'm tired of all such ambiguities and misunderstandings... Too much
mistakes of this kind when I cannot logically explain where's the problem. I
have to brandish my tambourine too often (some kind of  heuristic method)
:))  I thank god when someone (like dear TeamB-members) can help me with
such problems but otherwise it is go-slow strike...

Re:DBRichEdit doesn't show Text-field in MSSQL6.5


Try increasing the BDE settings BLOB SIZE and/or BLOBS TO CACHE to help get
the data through the BDE successfully. Does the same thing work with a
2-tier app?
--
Dan Miser
www.distribucon.com

Quote
vavan <va...@santel.ru> wrote in message

news:84a5hi$1s88@forums.borland.com...
Quote
>     Smth. obscure is happening with Subj. I had a table with a Text-field,
> everything was OK. I used DBMemo to represent value of that field. Then
I've
> added one more Text-field - woe is me! I could see in client that field is
> always empty (though really it wasn't empty

Re:DBRichEdit doesn't show Text-field in MSSQL6.5


Dan, you are real wizard !!! When I set BLOBS TO CACHE to 256 my problem has
gone. I've read help topic and if I understand right I'm working with "dead
table open"? What does it mean? Now in my dataset about 245 records, but
when there will be much more records does that mean I have to increase the
value for this parameter?

I will post this question to another groups too...

Re:DBRichEdit doesn't show Text-field in MSSQL6.5


I seem to remember that -1 worked for unlimited BLOBs. It might just be
coercing it to a word value $FFFF though. You better not need more than
that! <g>
--
Dan Miser
www.distribucon.com

Quote
vavan <va...@santel.ru> wrote in message

news:851ilo$pp39@bornews.borland.com...
Now in my dataset about 245 records, but
Quote
> when there will be much more records does that mean I have to increase the
> value for this parameter?

Other Threads