Board index » delphi » input not shown until program restarted

input not shown until program restarted

Hello,

I am using Delphi 3.0 (build 5.83) with BDE.

I have a form with several TEdit and TMemo fields on it.

When the user presses the 'Ok'-button the following code will run:

Table1.Insert;
Table1.FieldByName('Name').AsString := Edit1.Text;
   :
   :
Table1.Post;

Then when I try to view the data, I do not see it, until after I
have restarted the program. Does anyone have a solution for this,
like a Table1.Refresh?

Thanks for your help,

Arjen

--
Arjen Meijer <mailto:meije...@hio.tem.nhl.nl>
Homepage: http://www.engineering.tem.nhl.nl/~meije400/
-----------------------------------------------------------
"My code never has bugs. It just develops random features."

 

Re:input not shown until program restarted


What do you mean when you say you try to view the data? What kind of
control are you viewing the data in? e.g. a dbgrid?
Also, are you trapping errors in your code? If you are, then how exactly
are you trapping them?

In article <348D35EB.3...@hio.tem.nhl.nl>, meije...@hio.tem.nhl.nl
says...

Quote
> Hello,

> I am using Delphi 3.0 (build 5.83) with BDE.

> I have a form with several TEdit and TMemo fields on it.

> When the user presses the 'Ok'-button the following code will run:

> Table1.Insert;
> Table1.FieldByName('Name').AsString := Edit1.Text;
>    :
>    :
> Table1.Post;

> Then when I try to view the data, I do not see it, until after I
> have restarted the program. Does anyone have a solution for this,
> like a Table1.Refresh?

> Thanks for your help,

> Arjen

> --
> Arjen Meijer <mailto:meije...@hio.tem.nhl.nl>
> Homepage: http://www.engineering.tem.nhl.nl/~meije400/
> -----------------------------------------------------------
> "My code never has bugs. It just develops random features."

Other Threads