Board index » delphi » 'IB6.5 problem with linux(redhat71 (Server):SERVER/process_packet:

'IB6.5 problem with linux(redhat71 (Server):SERVER/process_packet:

Hi i got this error message after i install ib6.5
i'm using linux redhat 7.1

error message
'IB6.5 problem with linux(redhat71 (Server):SERVER/process_packet:
connection rejected for root)'

read from mers.com that i need to add a files hosts.equiv with localhost.
i did that but it still give me the same error message when i start the ib
services with this command
ibmgr -start.
what happen is that i notice that there are more then one ibserver been
start up when i use command
'ps -ae'
is this normal for ib6.5 cos the old version have only one ibguard and
ibserver

anyone can help me.
also my auto start did not work.
this is my script files
what did i done wrong??

-------------------------
: ${INTERBASE:=/opt/interbase}
: ${ISC_USER:=SYSDBA}
: ${ISC_PASSWORD:=masterkey}

ibserver_start()
{
su -c $INTERBASE'/bin/ibmgr -start -forever' | su sysdba

Quote
}

ibserver_stop()
{
$INTERBASE/bin/ibmgr -shut -password $ISC_PASSWORD

Quote
}

case $1 in
'start' )
 echo -e 'Interbase Server starting... c'
 ibserver_start ;;
'start_msg' )
 echo -e 'Interbase Server starting... c';;
'stop' )
 echo -e 'Interbase Server stopping... c'
 ibserver_stop ;;
'stop_msg' ) echo -e 'Interbase Server stopping... c';;

*) echo 'Usage:$0 { start | stop }'; exit 1;;

esac

exit 0
--------------

thanks in advance.

dorst...@yahoo.com

 

Re:'IB6.5 problem with linux(redhat71 (Server):SERVER/process_packet:


Quote
<dorst...@yahoo.com> wrote in message news:3ce0d390_1@dnews...

Hi,

You probably also need the entry    localhost.localdomain     in
/etc/hosts.equiv.

It also seems that you have some kind of firewalling active. Check that
communication i allowed on the necessary port(s), tcp/3050 for Interbase (+
tcp/3060 if any applications use JDBC).

Greetings,

Peter

Re:'IB6.5 problem with linux(redhat71 (Server):SERVER/process_packet:


Hi Peter,
thanks for you reply.
i  had the firewall disable and had the entry
localhost.localdomain and localhost
in the hosts.equiv
now it still doesn't work.

when i use comman
/opt/interbase/bin/ibmgr -start -forever
it still give me the same error message.
because of this error message i;m unable to use start ibserver correctly in

From
dorst...@yahoo.com

Quote
Peter Milesson <mi...@nospax.dragon.cz> wrote in message

news:3ce219fd_2@dnews...
Quote

> <dorst...@yahoo.com> wrote in message news:3ce0d390_1@dnews...

> Hi,

> You probably also need the entry    localhost.localdomain     in
> /etc/hosts.equiv.

> It also seems that you have some kind of firewalling active. Check that
> communication i allowed on the necessary port(s), tcp/3050 for Interbase
(+
> tcp/3060 if any applications use JDBC).

> Greetings,

> Peter

Other Threads