Board index » delphi » BDE Paradox - Windows 95 to XP

BDE Paradox - Windows 95 to XP

Hi, friends

I have created a Paradox DB using windows 95.

Now I installed Windows XP.

BCB4 does not recognize the DataBase.

How can I solve the problem ?

Thanks in advance

turcan

 

Re:BDE Paradox - Windows 95 to XP


What do you mean by "does not recognize the database"? What error message
are you getting when you try to run your program?

--
Bill
(TeamB cannot answer questions received via email)

Re:BDE Paradox - Windows 95 to XP


Hi Bill,

First of all thank you for your cooperation.

I had created an alias "lotobase" database.

The message I am getting now:

  in the Database Engine Error box:

                     Unknown database
                     Alias :  lotobase

Thank you again,

turcan

Quote
"Bill Todd (TeamB)" wrote:
> What do you mean by "does not recognize the database"? What error message
> are you getting when you try to run your program?

> --
> Bill
> (TeamB cannot answer questions received via email)

Re:BDE Paradox - Windows 95 to XP


When you open BDE Administrator and look at your aliases is lotobase still
there?

--
Bill
(TeamB cannot answer questions received via email)

Re:BDE Paradox - Windows 95 to XP


Bill, thanks again,

No it is not there, but I have not deleted my database,

     what could have happened ??

turcan

Quote
"Bill Todd (TeamB)" wrote:
> When you open BDE Administrator and look at your aliases is lotobase still
> there?

> --
> Bill
> (TeamB cannot answer questions received via email)

Re:BDE Paradox - Windows 95 to XP


No one will know what happened, unless you reinstalled the BDE.  You will
just have to redefine the alias.
--
Joseph Misko

Re:BDE Paradox - Windows 95 to XP


There is really no way to tell. Perhaps the BDE was reinstalled incorrectly
somewhere along the line and a new empty configuration file was installed.
Perhaps the XP conversion changed the registry. The solution is to recreate
the alias.

--
Bill
(TeamB cannot answer questions received via email)

Re:BDE Paradox - Windows 95 to XP


Thank you Joe, that's what I did and it worked

turcan

Quote
Joseph Misko wrote:
> No one will know what happened, unless you reinstalled the BDE.  You will
> just have to redefine the alias.
> --
> Joseph Misko

Re:BDE Paradox - Windows 95 to XP


Hi, Bill,

thanks a lot for your cooperation.
I just did not remember to redefine the alias

it works now

turcan

Quote
"Bill Todd (TeamB)" wrote:
> There is really no way to tell. Perhaps the BDE was reinstalled incorrectly
> somewhere along the line and a new empty configuration file was installed.
> Perhaps the XP conversion changed the registry. The solution is to recreate
> the alias.

> --
> Bill
> (TeamB cannot answer questions received via email)

Other Threads