Board index » delphi » Getting Error number 10036 - Unknown user name or password

Getting Error number 10036 - Unknown user name or password

Hi,

I am trying to define a connection to an MS SQL located on a Windows 2000
server from my work computer.

When I defined the database "MYDATABASE" through MS Enterprise Manager on
the server side the owner becomes "SVR1\Administrator".  When I set up the
BDE and defined the Database as MYDATABASE and the server name as
"MYSERVER".  Now when I try to open up the database I get the BDE error
#10036 - "Unknown user name or password" followed by BDE error #13059 -
"Login failed for user 'administrator'."  At other times I get the BDE error
#11277 "Can not locate or connect to SQL Server".  And this is the BDE
running on the server, itself.

But when I click on an OBDC defined connection, I am able to open up the
database without error.  In fact using ADO components I am able to access
the tables within a Delphi program.

What am I missing?  Can someone guide me towards a solution.  I have been
trying to figure this out for the past three weeks.

The reason I need to get this working is the application my company
purchased requires a MS SQL database accessed through the MS SQL (not SQL
Server) Type for the program to install.

Thank you,
John A

 

Re:Getting Error number 10036 - Unknown user name or password


Sounds like you define user and password in the DNS.
Try setting LoginPrompt to true
or UserName, Password  to their necessary values

Mick

Quote
John Antoniewicz <jan...@wgl.albanyga.org> wrote in message

news:3d0f5ba5$1_2@dnews...
Quote
> Hi,

> I am trying to define a connection to an MS SQL located on a Windows 2000
> server from my work computer.

> When I defined the database "MYDATABASE" through MS Enterprise Manager on
> the server side the owner becomes "SVR1\Administrator".  When I set up the
> BDE and defined the Database as MYDATABASE and the server name as
> "MYSERVER".  Now when I try to open up the database I get the BDE error
> #10036 - "Unknown user name or password" followed by BDE error #13059 -
> "Login failed for user 'administrator'."  At other times I get the BDE
error
> #11277 "Can not locate or connect to SQL Server".  And this is the BDE
> running on the server, itself.

> But when I click on an OBDC defined connection, I am able to open up the
> database without error.  In fact using ADO components I am able to access
> the tables within a Delphi program.

> What am I missing?  Can someone guide me towards a solution.  I have been
> trying to figure this out for the past three weeks.

> The reason I need to get this working is the application my company
> purchased requires a MS SQL database accessed through the MS SQL (not SQL
> Server) Type for the program to install.

> Thank you,
> John A

Other Threads