Board index » delphi » urgent help needed.

urgent help needed.

[ PC_HAULT.TXT 1K ]
hi every body
recently, i have faced two mysterious problems with using turbo pascal as i decribe below:
my system is 486, 66MHz, 32 meg RAM with about 7o meg hard empty for the moment

problem (1)
since almost seven years back i have been using turbo pascal 7.0. i used both ways of
approaching the package either through DOS or windows|DOS prompt (indirectly).
of course, with the second approach i have a much less memory available for compilation
and executions. also, if you are aware, there are two different commands one is "TURBO" and
the other is "TPX" that the second one(TPX) makes use of the entire legal and available
memory in the system, but over all i had no problem at all.

the recent problem is when i load the turbo pascal using the "TPX" command with out even
running any progam or compiling any thing, then i exit and run windows (3.1), exiting the
windows also without any performance, but at the exit moment, my PC get killed and the
following message:

Memory Allocation error
Cannot load COMMAND, system halted

now, if the sequence of the loading is changed which means first load win3.1, exit win,
then load turbo by typing TPX command in the promp, i dont have such  problem.

problem (2)
lately, i have upgraded my PC with 16 meg RAM, which now is working with 32 meg in total.
when loading the turbo with TPX, it takes me nearly ten seconds to receive 'IDE'.
and before i had 20 meg RAM i did not have any delay and almost in one or two seconds
the TPX was working successfully.

my attempt: i follwoed the suggestions made by the system
i have this set-up for virtual memory:
permanent memory 67,284(using BIOS) it is the suggestion by the system.

is there any thing going wrong with this PC or set-up?
btw: i re-instal the turbo pascal 7.0 but no difference resulted.

 

Re:urgent help needed.


Do you really need more than 32 MB RAM in Win3.1?
Try to disable the virtual memory. I have no idea if this will solve your
problems, but it might be worth the try. Unless you get any better
suggestions, of course.

/GreenGhost

Quote
>hi every body
>recently, i have faced two mysterious problems with using turbo pascal as i
decribe below:
>my system is 486, 66MHz, 32 meg RAM with about 7o meg hard empty for the
moment

>problem (1)
>since almost seven years back i have been using turbo pascal 7.0. i used
both ways of
>approaching the package either through DOS or windows|DOS prompt
(indirectly).
>of course, with the second approach i have a much less memory available for
compilation
>and executions. also, if you are aware, there are two different commands
one is "TURBO" and
>the other is "TPX" that the second one(TPX) makes use of the entire legal
and available
>memory in the system, but over all i had no problem at all.

>the recent problem is when i load the turbo pascal using the "TPX" command
with out even
>running any progam or compiling any thing, then i exit and run windows
(3.1), exiting the
>windows also without any performance, but at the exit moment, my PC get
killed and the
>following message:

>Memory Allocation error
>Cannot load COMMAND, system halted

>now, if the sequence of the loading is changed which means first load
win3.1, exit win,
>then load turbo by typing TPX command in the promp, i dont have such
problem.

>problem (2)
>lately, i have upgraded my PC with 16 meg RAM, which now is working with 32
meg in total.
>when loading the turbo with TPX, it takes me nearly ten seconds to receive
'IDE'.
>and before i had 20 meg RAM i did not have any delay and almost in one or
two seconds
>the TPX was working successfully.

>my attempt: i follwoed the suggestions made by the system
>i have this set-up for virtual memory:
>permanent memory 67,284(using BIOS) it is the suggestion by the system.

>is there any thing going wrong with this PC or set-up?
>btw: i re-instal the turbo pascal 7.0 but no difference resulted.

Other Threads