Board index » delphi » BDE 4.51 and InstallShield Express

BDE 4.51 and InstallShield Express

Hi
Im using Delphi 3.02 C/S, BDE 4.51.
I have created an Install for an app that uses MSSQL.
I have configured the BDE setup with my Alias.
I have ticked SQL Links, and ticked Microsoft SQL Server in the Available
Drivers list.

When I install my app on a PC that does not currently have the BDE, I get a
db-library error.

I then went back to the available drivers list and selected all of the
drivers, in the hope that the missing DLL's are in one of the other
drivers, to no avail.

Anone know what is going wrong? This is really a very simple installation,
and I recall worked fine with an earlier version of the BDE.

TIA

John Hair
Designer Systems Ltd

 

Re:BDE 4.51 and InstallShield Express


Hi John.

For Delphi to Sql Server connectivity to occur, you must install not only
the BDE and SQL Links, but Microsoft's SQL Server support.

Microsoft wants you to use the SQL Server CD-ROM to do an Install Client
Utilities Only installation on each workstation, but all you need to do to
give Sql Server 6.5 connectivity is copy the following files from the server
to each workstation (assuming you're using TCP/IP in addition to the
required Named Pipes):

dbmssocn.dll
dbnmpntw.dll
ntwdblib.dll

The dbmssocn.dll is for TCP/IP access, so if you're only using Named Pipes,
you may not need that DLL.

If you have need of other networking protocols, I'm not certain what DLLs
provide that support, but look in your SQL Server's SYSTEM32 folder for
similar DB*.DLL files that might apply and give it a shot.

Good luck,
Paul.

Quote
John Hair wrote in message <01bd5bf0$c481ee10$74c80980@johnsod>...
>Hi
>Im using Delphi 3.02 C/S, BDE 4.51.
>I have created an Install for an app that uses MSSQL.
>I have configured the BDE setup with my Alias.
>I have ticked SQL Links, and ticked Microsoft SQL Server in the Available
>Drivers list.

>When I install my app on a PC that does not currently have the BDE, I get a
>db-library error.

>I then went back to the available drivers list and selected all of the
>drivers, in the hope that the missing DLL's are in one of the other
>drivers, to no avail.

>Anone know what is going wrong? This is really a very simple installation,
>and I recall worked fine with an earlier version of the BDE.

>TIA

>John Hair
>Designer Systems Ltd

Other Threads