Board index » delphi » Delphi 2.01 exe on NT 4.0?

Delphi 2.01 exe on NT 4.0?

Should I be able to run a Delphi 2.01 exe on NT 4.0 Server? I can
install the IDE on the server, compile the source code, but it doesn't
run, some error msg involving kernel32.dll. Before I try to chase this
down, is what I'm doing simply not supposed to work? I know NT 4.0
uses different kernel32.dll, user32.dll, etc. etc.

 

Re:Delphi 2.01 exe on NT 4.0?


Quote
Chris Morris wrote:

> Should I be able to run a Delphi 2.01 exe on NT 4.0 Server? I can
> install the IDE on the server, compile the source code, but it doesn't
> run, some error msg involving kernel32.dll. Before I try to chase this
> down, is what I'm doing simply not supposed to work? I know NT 4.0
> uses different kernel32.dll, user32.dll, etc. etc.

If you post the actual error msg, I might know the cause... "Some error"
can be a lot of things...

Erik.

--
Need a custom component? Late on a project? Could use an util?
DOS Device driver? A VxD? NT drivers or services?
Applications of any kind?
Low rates, fast delivery!

When responding to news postings, please CC a copy to my email address.
Thanks.
Erik Sperling Johansen <e...@info-pro.no>

Re:Delphi 2.01 exe on NT 4.0?


On Thu, 13 Mar 1997 17:24:39 GMT, chri...@workmail.com (Chris Morris)
wrote:

Quote
>Should I be able to run a Delphi 2.01 exe on NT 4.0 Server? I can
>install the IDE on the server, compile the source code, but it doesn't
>run, some error msg involving kernel32.dll. Before I try to chase this
>down, is what I'm doing simply not supposed to work? I know NT 4.0
>uses different kernel32.dll, user32.dll, etc. etc.

You might want to re-install Delphi.  I'm running fine on NT4.0
workstation, so I'm not sure if maybe NT Server is behaving
differently, but I doubt it.

Chuck Gadd
Director of Software Development, {*word*104} FX Communications.
e-mail:-cg...@{*word*104}-fx.com  http://www.{*word*104}-fx.com
Remove the - in front of my email address to send me e-mail.
*** I boycott businesses that send me unsolicited email adverti{*word*224}ts ***

Re:Delphi 2.01 exe on NT 4.0?


I have been doing all my development work running Delphi 2.01 on NT 4.0
Server version,
service pack 1, over the past 4 months, and have not come across what you
have describe.  It also worked with Delphi 2.0
Gene

Chris Morris <chri...@workmail.com> wrote in article
<332837fa.13463...@news.nbn.com>...

Quote
> Should I be able to run a Delphi 2.01 exe on NT 4.0 Server? I can
> install the IDE on the server, compile the source code, but it doesn't
> run, some error msg involving kernel32.dll. Before I try to chase this
> down, is what I'm doing simply not supposed to work? I know NT 4.0
> uses different kernel32.dll, user32.dll, etc. etc.

Re:Delphi 2.01 exe on NT 4.0?


Quote
Chris Morris wrote:

> Should I be able to run a Delphi 2.01 exe on NT 4.0 Server? I can
> install the IDE on the server, compile the source code, but it doesn't
> run, some error msg involving kernel32.dll. Before I try to chase this
> down, is what I'm doing simply not supposed to work? I know NT 4.0
> uses different kernel32.dll, user32.dll, etc. etc.

Hi there
I have Delphi 2.01 installed on NT 4.0, and runs like a charm.
I've had no problems either compiling, nor runnung my executables

Good luck
James

Re:Delphi 2.01 exe on NT 4.0?


Quote
Chris Morris wrote:

> Should I be able to run a Delphi 2.01 exe on NT 4.0 Server? I can
> install the IDE on the server, compile the source code, but it doesn't
> run, some error msg involving kernel32.dll. Before I try to chase this
> down, is what I'm doing simply not supposed to work? I know NT 4.0
> uses different kernel32.dll, user32.dll, etc. etc.

I do all the time. Try a simpler app to prove it.

Re:Delphi 2.01 exe on NT 4.0?


I run Delphi 2.01 on NT 4.0 Server (Service Pack 1) for all my development
work, and it has been running fine since I started using it in November
1996.  I would try uninstalling and then reinstalling Delphi 2 under NT.
(I have my computer setup as a dual-boot system, so I have one version of
Delphi 2 installed under Windows 95, and another under NT 4.0
Gene

Marc Batchelor <mbatc...@appsource.com> wrote in article
<333748BB.5...@appsource.com>...

Quote
> Chris Morris wrote:

> > Should I be able to run a Delphi 2.01 exe on NT 4.0 Server? I can
> > install the IDE on the server, compile the source code, but it doesn't
> > run, some error msg involving kernel32.dll. Before I try to chase this
> > down, is what I'm doing simply not supposed to work? I know NT 4.0
> > uses different kernel32.dll, user32.dll, etc. etc.

> I do all the time. Try a simpler app to prove it.

Other Threads