Board index » delphi » Quick Report

Quick Report

Hello,

I have just downloaded the Quick Report update for Delphi 3.01...yet I
still have various problems with my reports:

    1-     I have an HP 5 printer, and I keep getting insufficient
memory when I print some of my reports - this occurs sporadically, and
not with all reports.  This printer has 4 RAM, and this problem never
occurs with any other applications - MS Applications for example.

    2-    Every time I view a quick report form at design time, I lose
the captions of all components.  I would normally fix this problem by
retyping the captions of all components, or change the datafield for the
dataaware components.  This is tends to be annoying at all times.

    3-    I would like the OutputBin property of the reportsettings to
be set as the default setting of the HP 5 printer.  Then I would like to
give the user the choice to alter the OutputBin at runtime as they may
desire.  First, I can't set the OutputBin property to be the default
setting of the printer.  Second, even if a user changes the printer
setting at runtime from within the quickreport, the report still gets
printed at the first tray - I setting I assigned for my OutputBin
property at design time.

    4-    A problem occurs whenever I try to print some of my reports.
I get the message 'Can't load the Quickrpt.pas unit, try to reload
it?'.  This problem disappears if I go to the printer settings and
without doing any changes, I press ok.  I then exit and print the report
with no problems.

    I would really appreciate it if any one would suggest any solutions
to my problems!

Amjad Hanouneh,
g...@planet.edu

P.S.  I develop all my applications on a Netware 4.12 environment!

 

Re:Quick Report


Quote
Amjad Hanouneh wrote:

> Hello,

> I have just downloaded the Quick Report update for Delphi 3.01...yet I
> still have various problems with my reports:

>     1-     I have an HP 5 printer, and I keep getting insufficient
> memory when I print some of my reports - this occurs sporadically, and
> not with all reports.  This printer has 4 RAM, and this problem never
> occurs with any other applications - MS Applications for example.

>     2-    Every time I view a quick report form at design time, I lose
> the captions of all components.  I would normally fix this problem by
> retyping the captions of all components, or change the datafield for the
> dataaware components.  This is tends to be annoying at all times.

>     3-    I would like the OutputBin property of the reportsettings to
> be set as the default setting of the HP 5 printer.  Then I would like to
> give the user the choice to alter the OutputBin at runtime as they may
> desire.  First, I can't set the OutputBin property to be the default
> setting of the printer.  Second, even if a user changes the printer
> setting at runtime from within the quickreport, the report still gets
> printed at the first tray - I setting I assigned for my OutputBin
> property at design time.

>     4-    A problem occurs whenever I try to print some of my reports.
> I get the message 'Can't load the Quickrpt.pas unit, try to reload
> it?'.  This problem disappears if I go to the printer settings and
> without doing any changes, I press ok.  I then exit and print the report
> with no problems.

>     I would really appreciate it if any one would suggest any solutions
> to my problems!

> Amjad Hanouneh,
> g...@planet.edu

> P.S.  I develop all my applications on a Netware 4.12 environment!

Regarding question 4.. did you recompile/reinstall the package.

Other Threads