Board index » delphi » InstallShield Express + BDE + MS Access Database

InstallShield Express + BDE + MS Access Database

Hi,

I have an MS Access database which is connected to my Delphi 5 application
via DBE. This works fine!

Now, I use InstallShield Express to install my application + the MS access
database + BDE. Is it possible to configure the BDE in such a way that this
works without having to force the end user to create the database alias
manually? I try, but I get the error:

  Cannot load an IDAPI service library:
  File: [...] DAO3023.ddl
  Alias: my_ms_access_alias

--
Pascal

 

Re:InstallShield Express + BDE + MS Access Database


Quote
>Now, I use InstallShield Express to install my application + the MS access
>database + BDE. Is it possible to configure the BDE in such a way that this
>works without having to force the end user to create the database alias
>manually? I try, but I get the error:

You can use a Tdatabase so you do not need an Alias but there error you are
getting indicates that DAO 3.0 is not installed on this machine.

Quote
>  Cannot load an IDAPI service library:
>  File: [...] DAO3023.ddl

If you are trying to use DAO 3.5 instead of 3.0 you can change the Dll32
parameter in code
http://www.borland.com/devsupport/bde/bdeapiex/dbiopencfginfolist.html

--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Re:InstallShield Express + BDE + MS Access Database


--
Pascal

"Brian Bushay TeamB" <BBus...@Nmpls.com> wrote in message
news:0rhu5u4s1et39rom2qlom9hlgg7a7ipnc4@4ax.com...

Quote

> >Now, I use InstallShield Express to install my application + the MS
access
> >database + BDE. Is it possible to configure the BDE in such a way that
this
> >works without having to force the end user to create the database alias
> >manually? I try, but I get the error:
> You can use a Tdatabase so you do not need an Alias but there error you
are
> getting indicates that DAO 3.0 is not installed on this machine.

How could TDatabase work without an Alias? I configured the alias via my
computer | control panel | ODBC and then it works on my computer!!! If I
configure the link via BDE, it does not work. Is this because of the fact
that I DAO 3.0 is not installed?
Quote

> >  Cannot load an IDAPI service library:
> >  File: [...] DAO3023.ddl

> If you are trying to use DAO 3.5 instead of 3.0 you can change the Dll32
> parameter in code
> http://www.borland.com/devsupport/bde/bdeapiex/dbiopencfginfolist.html

> --
> Brian Bushay (TeamB)
> Bbus...@NMPLS.com

Re:InstallShield Express + BDE + MS Access Database


Quote
>How could TDatabase work without an Alias?

Double click on the Tdatabase.  
Set the Driver Name
Instead of filling in the Alias box press the defaults button then set the
parameter values like you would set the alias.

Quote
> I configured the alias via my
>computer | control panel | ODBC and then it works on my computer!!!
>If I
>configure the link via BDE, it does not work. Is this because of the fact
>that I DAO 3.0 is not installed?

How do you configure the link Via BDE?
If you don't have DAO installed then it isn't going to work.

--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Other Threads