Board index » delphi » Help! Delphi 1.0 hates Access 2.0 :(

Help! Delphi 1.0 hates Access 2.0 :(

Help!

I simply cannot get Delphi 1.0 to connect
to an Access 2.0 database.

I get "Incorrect number of parameters" or
"Incorrect parameter".

I desperately need this fixed.  Any help would be
greatly appreciated!

 

Re:Help! Delphi 1.0 hates Access 2.0 :(


Quote
On Thu, 28 Mar 1996 17:35:18 GMT, gsch...@nise.com (Guy Schamp) wrote:
>Help!

>I simply cannot get Delphi 1.0 to connect
>to an Access 2.0 database.

>I get "Incorrect number of parameters" or
>"Incorrect parameter".

>I desperately need this fixed.  Any help would be
>greatly appreciated!

I had this problem and fought it for several weeks.  I finaly got it
to work as advertised only by installing Access 2.0.  Once installed
the ODBC seemed to function fine.  Note that all other recommended
solutions such as downloading the latest ODBC and such were  waste of
time.  If you want to get there quickly, install Access 2.0, perhapts
just the ODBC component, and it will work great.

                        ja...@sisna.com

Re:Help! Delphi 1.0 hates Access 2.0 :(


Guy,

Delphi to Access is no problem:

1. Create an ODBC datasouce that points to your MS-Access database.

NB You will need ODBC version 2.x (the dll's are on your Delphi
install disks) and the "Access 2.0 for MS-Office" odbc driver
that comes with MS-Office.

2. Run BDECFG and switch AutoODBC to True in your system tab.

3. Drop a database on your form and connect it to the ODBC
datasource that you named in 1 and then chosse a table.

Regards,

Peter

In article <315ac179.1640...@news.teleport.com>, Guy Schamp

Quote
(gsch...@nise.com) writes: >Help!

>I simply cannot get Delphi 1.0 to connect
>to an Access 2.0 database.

>I get "Incorrect number of parameters" or
>"Incorrect parameter".

>I desperately need this fixed.  Any help would be
>greatly appreciated!

                           Peter J Smith
                           IPA  Software
      Tel: +44-131-558-3174             Fax: +44-171-919-6142
                    Web: www.ibmpcug.co.uk/~tvc15

Re:Help! Delphi 1.0 hates Access 2.0 :(


Quote
In article <315c56dd.2699489@news>, ja...@sisna.com wrote:
>I had this problem and fought it for several weeks.  I finaly got it
>to work as advertised only by installing Access 2.0.  Once installed
>the ODBC seemed to function fine.  Note that all other recommended
>solutions such as downloading the latest ODBC and such were  waste of

If you don't get the updated ODBC driver from MS, then you won't be able
to write to the database (ODBC error -1003 except for MS-Office apps)...

-
=\
 *=- R.Moberg, CD-Player Pro info @ http://www.sn.no/~mobergru/
=/

Other Threads