Board index » delphi » Paradox tabels Loosing Data

Paradox tabels Loosing Data

I am loosing data in my Paradox Tables.

I have Localshare set to true and I am using DBIsavechanges on the table in
question.

These are on NT workstation 4.0 sp3.

I remember somebody saying something about an NT registry setting having to
do with opportunistic locking.  Can someone point me to this?

If anybody has any other suggestions, PLEASE, PLEASE respond!  I am starting
to loose the trust of my employers on this.

Thanks,
Mike

 

Re:Paradox tabels Loosing Data


Under what situation are you losing data?  Local Share=true and DbiSaveChanges
are not both needed, one or the other should suffice in the case of abnormal
termination or power failure.

Quote
Mike wrote:

> I am loosing data in my Paradox Tables.

> I have Localshare set to true and I am using DBIsavechanges on the table in
> question.

> These are on NT workstation 4.0 sp3.

> I remember somebody saying something about an NT registry setting having to
> do with opportunistic locking.  Can someone point me to this?

> If anybody has any other suggestions, PLEASE, PLEASE respond!  I am starting
> to loose the trust of my employers on this.

> Thanks,
> Mike

--
Jeff Overcash (TeamB)
      (Please do not email me directly unless  asked. Thank You)
If there is somebody up there could they throw me down a line.  Just a
little helping hand just a little understanding.  Just some answers to the
questions that surround me now.  If there's somebody up there could
they throw me down a line.               (Fish)

Re:Paradox tabels Loosing Data


Quote
> Under what situation are you losing data?  Local Share=true and
DbiSaveChanges
> are not both needed, one or the other should suffice in the case of
abnormal
> termination or power failure.

 I understand that they should be enough, but somehow it is still loosing
data.  I have 4 out of 170 or so that are loosing data.  I have not tracked
down the circumstances yet.  They say they do not have a power fluctuation,
but they are not on UPS either.

Re:Paradox tabels Loosing Data


I found these links searching for "opportunistic locking" on Deja.com in the
*delphi* forums.

http://www.borland.com/devsupport/delphi/faq/FAQ1013D.html
http://support.microsoft.com/support/kb/articles/Q129/2/02.asp
http://support.microsoft.com/support/kb/articles/Q219/0/22.ASP

brian

Quote
"Mike" <akinNOS...@theshop.net> wrote in message

news:89gvjo$jp25@bornews.borland.com...
Quote
> I am loosing data in my Paradox Tables.

> I have Localshare set to true and I am using DBIsavechanges on the table
in
> question.

> These are on NT workstation 4.0 sp3.

> I remember somebody saying something about an NT registry setting having
to
> do with opportunistic locking.  Can someone point me to this?

> If anybody has any other suggestions, PLEASE, PLEASE respond!  I am
starting
> to loose the trust of my employers on this.

> Thanks,
> Mike

Re:Paradox tabels Loosing Data


From the very little bit of information you have given this sounds like it
might be a BDE configuration problem on some of the machines. You must have
Local Share set to True on _every_ workstation.

--
Bill

Bill Todd (TeamB)
(TeamB cannot respond to questions received via email)

Re:Paradox tabels Loosing Data


I agree with Bill that you might not have Local share set on all the machines.
Also is this the same 4 computers or even the same 4 users having this problem?  

One thing might be if you are using cached updates and the user has to post/save
before closing the form and they don't, then when the dataset is closed it
throws away the changes and does not apply them.  I had this with one user where
I edned up having to check the updates pending before allowing a form to close.
In my case only one user was trying to close without saving the changes so it
looked like only one machine was having problems losing data.

Quote
Mike wrote:

> > Under what situation are you losing data?  Local Share=true and
> DbiSaveChanges
> > are not both needed, one or the other should suffice in the case of
> abnormal
> > termination or power failure.

>  I understand that they should be enough, but somehow it is still loosing
> data.  I have 4 out of 170 or so that are loosing data.  I have not tracked
> down the circumstances yet.  They say they do not have a power fluctuation,
> but they are not on UPS either.

--
Jeff Overcash (TeamB)
      (Please do not email me directly unless  asked. Thank You)
If there is somebody up there could they throw me down a line.  Just a
little helping hand just a little understanding.  Just some answers to the
questions that surround me now.  If there's somebody up there could
they throw me down a line.               (Fish)

Re:Paradox tabels Loosing Data


Quote
>I have Localshare set to true and I am using DBIsavechanges on the table in
>question.

>These are on NT workstation 4.0 sp3.

>I remember somebody saying something about an NT registry setting having to
>do with opportunistic locking.  Can someone point me to this?

For the opportunistic locking reference
http://support.microsoft.com/support/kb/articles/Q129/2/02.asp

Also update that service pack to at least version 4
Make sure you are not using the Ipx/Spx protocol

--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Re:Paradox tabels Loosing Data


Hey people,
what about the limitation of paradox tables size?
Maybe it's necessary to restructure the version and/or block size because
reached the mx. size.
(Try using de restructure utility from borland.)
Am I right?

Vilson Cristiano G?rtner - vgart...@iname.com

Quote
>I agree with Bill that you might not have Local share set on all the
machines.
>Also is this the same 4 computers or even the same 4 users having this
problem?
>................

Re:Paradox tabels Loosing Data


They are.

These are single user applications on single disconnected PC's

Bill Todd (TeamB) <b...@dbginc.com> wrote in message
news:89hjr6$kad7@bornews.borland.com...

Quote
> From the very little bit of information you have given this sounds like it
> might be a BDE configuration problem on some of the machines. You must
have
> Local Share set to True on _every_ workstation.

> --
> Bill

> Bill Todd (TeamB)
> (TeamB cannot respond to questions received via email)

Re:Paradox tabels Loosing Data


These files have about 500 records Max.

Quote
gartner <vgart...@iname.com> wrote in message

news:89j5v2$liu2@bornews.borland.com...
Quote
> Hey people,
> what about the limitation of paradox tables size?
> Maybe it's necessary to restructure the version and/or block size because
> reached the mx. size.
> (Try using de restructure utility from borland.)
> Am I right?

> Vilson Cristiano G?rtner - vgart...@iname.com

> >I agree with Bill that you might not have Local share set on all the
> machines.
> >Also is this the same 4 computers or even the same 4 users having this
> problem?
> >................

Re:Paradox tabels Loosing Data


Quote
> http://www.borland.com/devsupport/delphi/faq/FAQ1013D.html

This link redirects to:
  http://community.borland.com/article/0,1410,16013,00.html

And gives this error:
   an error occurred while processing this directive]

BTW, does anybody think the community site is SLOW?

Re:Paradox tabels Loosing Data


Why do you say, at least V4?
Quote
> Also update that service pack to at least version 4
> Make sure you are not using the Ipx/Spx protocol

Re:Paradox tabels Loosing Data


He would get the "table is full" error in that case.

--
Bill

Bill Todd (TeamB)
(TeamB cannot respond to questions received via email)

Re:Paradox tabels Loosing Data


In addition to what Jeff said about cached updates, the same thing will
happen if you are using TClientDataSet and the user can get out without
ApplyUpdates being called. Also, if you are using transactions and the
transaction is rolled back you could lose data.

--
Bill

Bill Todd (TeamB)
(TeamB cannot respond to questions received via email)

Re:Paradox tabels Loosing Data


Quote
>Why do you say, at least V4?

Previous resonances to corruption on NT server have indicated that problems
where fixed by applying service pack 4

--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Go to page: [1] [2]

Other Threads