Board index » delphi » Problem with graphic card or monitor or...?

Problem with graphic card or monitor or...?

Hello everybody!

I have a problem I have to solve till yesterday. So fast help would be
greatly appriciated.

First what I use:
D4 C/S, Paradox tables
Application was developed for 1024X768 resolution. I first developed it on
D3 C/S and ported it to D4 C/S (had some problems with QR's but now it
works)

I've written a DB app for a special customer. It works fine on his computer
and on our computers. Now I've tried to install program to some other
people and... On one machine works fine, but on other two it has a bit of a
problem. Even when I set their resolution to 1024X768 it acts as resolution
was smaller (some input fields 'fall off' the form), also the intro screen
looks funny: I have a bmp and few labels on form and an avi bottom right.
On theese computers the form is bigger (it doesn't stretch bmp so there is
a gray area on right and bottom). Avi is now at bottom right in gray area.

App looks like this:
I have a grid placed on form and a button at the bottom of form to open
panel with input fields (Align properties seem fine)

The wierd thing is that this happened on 14" and 17" monitors (all the
others including me use 15"). So is it possible that monitors did it?

Thanxs!

Lucijan

 

Re:Problem with graphic card or monitor or...?


Quote
Lucijan Sulic <luci...@altavista.net> wrote in message

news:01becc3f$7f38fe00$6806a8c0@lsulic...

Quote
> I have a problem I have to solve till yesterday. So fast help would be
> greatly appriciated.

> Application was developed for 1024X768 resolution.

Yikes. This makes it the least portable PC application *ever* <g>

Quote
> I've written a DB app for a special customer. It works fine on his
computer
> and on our computers. Now I've tried to install program to some other
> people and... On one machine works fine, but on other two it has a bit of
a
> problem. Even when I set their resolution to 1024X768 it acts as
resolution
> was smaller (some input fields 'fall off' the form), also the intro screen
> looks funny: I have a bmp and few labels on form and an avi bottom right.
> On theese computers the form is bigger (it doesn't stretch bmp so there is
> a gray area on right and bottom). Avi is now at bottom right in gray area.

> The wierd thing is that this happened on 14" and 17" monitors (all the
> others including me use 15"). So is it possible that monitors did it?

This is an FAQ. The problem is a combination of the different screen
resolutions, and that fact that some people use large fonts, and some
use small. You really should have to change the user's screen resolution
to make the app run properly - would you accept this?

Go back to your application, and for each form set the Scaled property
to False, and use a TrueType font (Arial is a good choice) for each form.
Also, add a little extra space around your controls (most users appreciate
this anyway).

This should fix 99.9% of your problems.

--
Jeremy Collins
Kansai Business Systems
http://www.kansai.co.uk/

Re:Problem with graphic card or monitor or...?


The classic font-size problem.  The one-time fix is to
select the same "Small Fonts" or "Large Fonts" setting on
the problem computer that you have on the development
machine.

That's fine if you'll be doing all the installations
yourself, but you may want to add code that checks the font
size and warns users if it's not set correctly.  Of course,
the ideal solution would be to alter the application to work
with all common settings, perhaps by playing with the
AutoScale properties (or is that AutoSize?).

Heracles

Sent from RemarQ http://www.remarq.com/?z The Internet's Discussion Network
The fastest and easiest way to search and participate in Usenet - Free!

Other Threads