Board index » delphi » Access violation error when running program from the IDE D3.01/Oracle

Access violation error when running program from the IDE D3.01/Oracle

I'm writing a program that access an Oracle database(D3.01/BDE4.01). When i
try to run the program from the IDE this one produce an Access violation
error message. When i compile the program and runs it outside the IDE all
seem to work properly. This means that i can't debug the program !!
How I solve this?

 

Re:Access violation error when running program from the IDE D3.01/Oracle


See the previous message thread entitled 'D3 De{*word*81} + Oracle 7.3'
for some possible clues.

On 22 Oct 1997 07:22:37 GMT, "Sergio Sette"

Quote
<Sergio.Se...@provincia.bz.it> wrote:

>I'm writing a program that access an Oracle database(D3.01/BDE4.01). When i
>try to run the program from the IDE this one produce an Access violation
>error message. When i compile the program and runs it outside the IDE all
>seem to work properly. This means that i can't debug the program !!
>How I solve this?

Re:Access violation error when running program from the IDE D3.01/Oracle


ciao sergio,
  are you using Windows NT 4.0 - i've expereienced the same problem
under this OS
peter

Sergio Sette schrieb:

Quote
> I'm writing a program that access an Oracle database(D3.01/BDE4.01).
> When i
> try to run the program from the IDE this one produce an Access
> violation
> error message. When i compile the program and runs it outside the IDE
> all
> seem to work properly. This means that i can't debug the program !!
> How I solve this?

--
------------------------------------------------------
| Dr.Peter Wilk                                      |
| Europ Assistance Ges.m.b.H.                        |
| http://ourworls.compuserve.com/homepages/PeterWilk |
------------------------------------------------------

Re:Access violation error when running program from the IDE D3.01/Oracle


Yes I've also experienced under Windows NT, but I think the problem is
from Oracle.
The world was beautiful with Delphi , NT and Ora 7.3.2
One day I got Ora 7.3.3 by ODP and I got the same error message every
time when I run inside the IDE. I solved the problem with Ora 8.0.3

Check your Ora version, You may be using 7.3.3

Quote
Peter Wilk wrote:

> ciao sergio,
>   are you using Windows NT 4.0 - i've expereienced the same problem
> under this OS
> peter

> Sergio Sette schrieb:

> > I'm writing a program that access an Oracle database(D3.01/BDE4.01).
> > When i
> > try to run the program from the IDE this one produce an Access
> > violation
> > error message. When i compile the program and runs it outside the IDE
> > all
> > seem to work properly. This means that i can't debug the program !!
> > How I solve this?

> --
> ------------------------------------------------------
> | Dr.Peter Wilk                                      |
> | Europ Assistance Ges.m.b.H.                        |
> | http://ourworls.compuserve.com/homepages/PeterWilk |
> ------------------------------------------------------

Other Threads