Board index » delphi » "Class not registered" Error after installation

"Class not registered" Error after installation

                Hello ,

I,ve created a program in delphi5, an created a installation set with
installshield . When i try to run this on a clean NT4 system (sp6 + IE5.5
installed ) i get some strange problems :

- On startup i get a messagebox with the message "class not registered"error
- After pressing OK (i don't think it's ok but ...)
- I get a exception error "Access violation at address 0050EA92 in module
'redacteur.exe' Read of Address 0000000C
- AFtrer pressing OK ( srtill not ok according to my opinion) i get the
Main form displayed. This is not OK , the toolbar ar to small (lower part
are cut off ?)
- Some dialog boxes work , some others give me errors (same error , other
adres)

If noticed that delphi creates a  TLB foile from my project with indere a
interface to ITest (?) .
Why is he doing this , i can't find any reason ?
How do i find out which class he is try to use ?
How do i map this error adres to a line in my code ?

                can anybody help me .....

                luc

 

Re:"Class not registered" Error after installation


What does your application do?

--
have fun

Binh Ly
www.techvanguards.com

Quote
"Luc Willems" <willems....@pandora.be> wrote in message

news:3ac6f956_1@dnews...
Quote

>                 Hello ,

> I,ve created a program in delphi5, an created a installation set with
> installshield . When i try to run this on a clean NT4 system (sp6 + IE5.5
> installed ) i get some strange problems :

Other Threads