Board index » delphi » "Class not registered" error

"Class not registered" error

My program uses the Internet components of Delphi3. It runs well on my PC
but not on other PC's (without Delphi installed). On these PC's the program
crashes with this error at start-up:
'Exception EOleSysError: Class not registered'.
Why should a class be 'registered'? And how can I solve this? And why does
it run without problems on my own PC and not on other PC's?

All help greatly appreciated!

---
Walther Schoonenberg
Email: walth...@xs4all.nl

 

Re:"Class not registered" error


Quote
Walther Schoonenberg wrote:
> My program uses the Internet components of Delphi3. It runs well on my PC
> but not on other PC's (without Delphi installed). On these PC's the program
> crashes with this error at start-up:
> 'Exception EOleSysError: Class not registered'.
> Why should a class be 'registered'? And how can I solve this? And why does
> it run without problems on my own PC and not on other PC's?

> All help greatly appreciated!

> ---
> Walther Schoonenberg
> Email: walth...@xs4all.nl

Can't tell why it crashes right now. But can tell you that registering a class
has nothing to do with ' letting Bill Gates know that you use it ' !!!!!!!

        Allen.(9711...@multihexa.com)

Re:"Class not registered" error


Quote
>   "Walther Schoonenberg" <wschoonenb...@econ.vu.nl> writes:
>  My program uses the Internet components of Delphi3. It runs well on my PC
>  but not on other PC's (without Delphi installed). On these PC's the program
>  crashes with this error at start-up:

You need to install and register severall DLL's and OCX's in the target machines. Which are dependent on what controls you use.

johan

Re:"Class not registered" error


On Fri, 16 Jan 1998 13:12:10 +0100, "Walther Schoonenberg"

Quote
<wschoonenb...@econ.vu.nl> wrote:
>My program uses the Internet components of Delphi3. It runs well on my PC
>but not on other PC's (without Delphi installed). On these PC's the program
>crashes with this error at start-up:
>'Exception EOleSysError: Class not registered'.
>Why should a class be 'registered'? And how can I solve this? And why does
>it run without problems on my own PC and not on other PC's?

>All help greatly appreciated!

>---
>Walther Schoonenberg
>Email: walth...@xs4all.nl

Walthar,

        The Internet components are OCX's and must be installed on
each machine that is running the program. The 'Class not registered'
error is caused by these OCX's not being present and registered in the
registry(use RegSrv32.exe to register the components).

                                        Good Luck,
                                                Mike

Re:"Class not registered" error


Yep ...i got this problem too... Buddy, if you have found the solution
to this problem, can you kindly help me to get over it please? A million
thanx!

Jerry
Email: jerry...@usa.net

Other Threads