Board index » delphi » Weird behaviour of D3 c/s IDE with Oracle 7.3

Weird behaviour of D3 c/s IDE with Oracle 7.3

I've noticed a couple of strange and very annoying problems that I think
might be due to Oracle SQL*Net.

1. Using the de{*word*81} is OK until you hit Ctrl+F7 to inspect a variable.
Then the machine hangs. Only happens with Oracle, not SQL Server.

2. When I change my TDatabase object to use a SQL Server BDE alias
instead and try to edit the fields of any TQuery object, Delphi tries to
connect to the Oracle BDE alias it used before, even though there is no
longer any reference to this alias anywhere in the project files.

Can anyone please (a) confirm my suspicions and (b) suggest a solution?
TIA
--
Tony Lavelle
Hyrax Computer Systems Ltd, UK
(remove .spamtrap from return address before replying)

 

Re:Weird behaviour of D3 c/s IDE with Oracle 7.3


Tony,

Have you removed the Oracle trace facility?  This conflicts with the
de{*word*81}.

Gerald

Quote
Tony Lavelle wrote:

> I've noticed a couple of strange and very annoying problems that I think
> might be due to Oracle SQL*Net.

> 1. Using the de{*word*81} is OK until you hit Ctrl+F7 to inspect a variable.
> Then the machine hangs. Only happens with Oracle, not SQL Server.

> 2. When I change my TDatabase object to use a SQL Server BDE alias
> instead and try to edit the fields of any TQuery object, Delphi tries to
> connect to the Oracle BDE alias it used before, even though there is no
> longer any reference to this alias anywhere in the project files.

> Can anyone please (a) confirm my suspicions and (b) suggest a solution?
> TIA
> --
> Tony Lavelle
> Hyrax Computer Systems Ltd, UK
> (remove .spamtrap from return address before replying)

Other Threads