Board index » delphi » possible BDE Transaction bug

possible BDE Transaction bug

I've run across a repeatable bug that causes an AV in the BDE when
using local Paradox tables. It can be seen by:

   start a transaction
   open a table
   edit a record
   post the change
   close the table
   reopen the same table
   try to edit the same record as above, and the exception occurs.

does anyone know if this is indeed a bug, or is the BDE limited in
someway when performing transaction processing against local Paradox
tables. I've used transactions like this in many places where I wasn't
editing the same record more than once, without any problems.

my configuration is: Delphi 3.0, NT 4.0, BDE 4.0.0.36

TIA
Larry

 

Re:possible BDE Transaction bug


J. Larry Schlatre Jr. wrote in message
<349727e5.322...@news.mindspring.com>...

Quote
>I've run across a repeatable bug that causes an AV in the BDE when
>using local Paradox tables. It can be seen by:

>   start a transaction
>   open a table
>   edit a record
>   post the change
>   close the table
>   reopen the same table
>   try to edit the same record as above, and the exception occurs.

>does anyone know if this is indeed a bug, or is the BDE limited in
>someway when performing transaction processing against local Paradox
>tables. I've used transactions like this in many places where I wasn't
>editing the same record more than once, without any problems.

>my configuration is: Delphi 3.0, NT 4.0, BDE 4.0.0.36

>TIA
>Larry

This is cut&paste from Borland.
http://www.borland.com/devsupport/bde/fixes/401/paradox.html

It describes bug fixes from version 4.0 to 4.01 in the BDE

*******************************************
Area: paradox
Reference Number: 58

Sub Area: Transactions

Date Reported: 6/9/97

Severity: Infrequently Encountered

Type: Crash

Problem:

Running the following program will cause an AV.  The error
occurs when a transaction is active and a record is
updated twice.  The table must be closed and then
re-opened for the problem to occur.
*****************************************************************

If this is related to your problem, you could try to upgrade the BDE.

?yvind Taugl
R&D Manager Control IT AS
Norway

Other Threads