Board index » delphi » BDE 5.1 AutoCommit and Explicit Commits not working

BDE 5.1 AutoCommit and Explicit Commits not working

Running Oracle 8.0.4 at the server and 8.0.5 at the workstation.

Autocommit and explicit commits don't seem to work anymore.

Example:

Add a record to a table.  While that screen is still open,
go to another program, open the table, the record is
not visible.  Close the screen that added the table, go
to other program and refresh table, record appears.

I have a posting algorithm that does an explicit post
on the a parent table, and the child table fails when
trying to post.  I am not rolling the two inserts in
one transaction.  

What am I doing wrong (or what is the new feature)?

--
Thomas Miller
Delphi Client/Server Certified Developer
BSS Accounting & Distribution Software
BSS Enterprise Accounting FrameWork

http://www.bss-software.com

 

Re:BDE 5.1 AutoCommit and Explicit Commits not working


I was worried I was doing something wrong.  I guess I can stop pulling
my hair out.  This is very disappointing.  It will take them months
to get a fix out.  I did some playing again, and it seem to start
working fine.  Then I got on another system, and it went write back
to NOT working.  I guess the BDE is single user when it comes to
Oracle.  I see other people are having problems with Stored procedures
too.  

I guess people should wait a for a few more releases of D5 and the BDE
before upgrading!!  I guess I should upgrade to Delphi 3 :(

Quote
"Mio-Nino P. Marquez" wrote:

> Tom:

> Hi.

> We're having similar problems. It appears to be a problem with the BDE
> 5.1 (too bad I applied it immediately after downloading!)
> I've posted a message (re: Problem: Oracle and BDE 5.1) about this
> before in this NG but got no response.

> Still waiting for that long overdue BDE 5.1 Fix List and Known Issues
> document.

> Mio Marquez
> Delphi Developer

--
Thomas Miller
Delphi Client/Server Certified Developer
BSS Accounting & Distribution Software
BSS Enterprise Accounting FrameWork

http://www.bss-software.com

Re:BDE 5.1 AutoCommit and Explicit Commits not working


Tom:

Hi.

We're having similar problems. It appears to be a problem with the BDE
5.1 (too bad I applied it immediately after downloading!)
I've posted a message (re: Problem: Oracle and BDE 5.1) about this
before in this NG but got no response.

Still waiting for that long overdue BDE 5.1 Fix List and Known Issues
document.

Mio Marquez
Delphi Developer

Re:BDE 5.1 AutoCommit and Explicit Commits not working


Similar problems here too with Interbase backend.

How do I "downgrade" a BDE installation? Need to get my client's machines
working again.

Thanks,
Simon

Quote
tmiller wrote in message <37DDAE10.CD131...@bss-software.com>...
>I was worried I was doing something wrong.  I guess I can stop pulling
>my hair out.  This is very disappointing.  It will take them months
>to get a fix out.  I did some playing again, and it seem to start
>working fine.  Then I got on another system, and it went write back
>to NOT working

Re:BDE 5.1 AutoCommit and Explicit Commits not working


Now downgraded to BDE 5.01 update 3 - so far, all working again.

Simon

Re:BDE 5.1 AutoCommit and Explicit Commits not working


How did you downgrade?
Ronald Hinds

Quote
Simon <elvisdiablo99@**nospam**yahoo.com> wrote in message

news:7rlh0p$o131@forums.borland.com...
Quote
> Now downgraded to BDE 5.01 update 3 - so far, all working again.

> Simon

Re:BDE 5.1 AutoCommit and Explicit Commits not working


That pretty much cooks using D5 for several months.  Guess we
all can hurry up and wait (again) to use the latest and
worst (oops, I meant greatest) of Delphi.

Quote
Simon wrote:

> Now downgraded to BDE 5.01 update 3 - so far, all working again.

> Simon

--
Thomas Miller
Delphi Client/Server Certified Developer
BSS Accounting & Distribution Software
BSS Enterprise Accounting FrameWork

http://www.bss-software.com

Re:BDE 5.1 AutoCommit and Explicit Commits not working


Backup up IDAPI.CFG and then delete BDE directory,  and then reinstall older
BDE and replace IDAPI.CFG.
Quote
Ronald Hinds wrote in message <7rllcg$o0...@forums.borland.com>...
>How did you downgrade?
>Ronald Hinds

>Simon <elvisdiablo99@**nospam**yahoo.com> wrote in message
>news:7rlh0p$o131@forums.borland.com...
>> Now downgraded to BDE 5.01 update 3 - so far, all working again.

>> Simon

Re:BDE 5.1 AutoCommit and Explicit Commits not working


Actually, I read somewhere yesterday (maybe BDE newsgroup)  that D5 will
actually work with BDE 5.0.

So far, after half a day of intensive use, that certainly appears to be the
case.

Simon

Quote
tmiller wrote in message <37DE5B0C.B4F5C...@bss-software.com>...
>That pretty much cooks using D5 for several months.

Re:BDE 5.1 AutoCommit and Explicit Commits not working


Quote
>Actually, I read somewhere yesterday (maybe BDE newsgroup)  that D5 will
>actually work with BDE 5.0.

Indeed it seems to work. I tested D5 and BDE 5.1 for my company and
also found backward compatibility bugs (see borland.public.bde) for
DB2 with BDE 5.1. When I downgraded BDE to 5.01 again all worked as
normal with Delphi 5. I don't know whether Borland will guarantee it
to work but BDE 5.01 is certainly far more stable as I understand from
various posts. My experiense seems to show that it works as well.

Other Threads