Board index » delphi » Problem with Alias\BDE (Possible Bug)- cashing old databse path

Problem with Alias\BDE (Possible Bug)- cashing old databse path

I have D4/BDE5 - I have changed the path in alias definition to a
different folder that contains additional tables.

Every time I try to assign a new table to a Tablename in Table
component , I see only an old list of available tables. When I try to
assign a name manually (bt typing) and set active to true, I am geting
an error showing an old path to alias.

I can see all the tables in BDE Explorer.

seems to me that it is a bug with BDE5.

In the meantine, how can I remove old path from allias. I even removed
and added alias. No change.

 

Re:Problem with Alias\BDE (Possible Bug)- cashing old databse path


Solved - just reboot PC!

Re:Problem with Alias\BDE (Possible Bug)- cashing old databse path


Quote
>I have D4/BDE5 - I have changed the path in alias definition to a
>different folder that contains additional tables.

Where /How are you changing the Alias?

--
Brian Bushay (TeamB)
Bbus...@DataGuidance.com

Re:Problem with Alias\BDE (Possible Bug)- cashing old databse path


I was changing Alias through BDE...(same name different path) & Apply

On Mon, 24 Aug 1998 01:37:32 GMT, BBus...@DataGuidance.com (Brian

Quote
Bushay TeamB) wrote:

>>I have D4/BDE5 - I have changed the path in alias definition to a
>>different folder that contains additional tables.

>Where /How are you changing the Alias?

Re:Problem with Alias\BDE (Possible Bug)- cashing old databse path


Quote
>I was changing Alias through BDE...(same name different path) & Apply

The BDE config gets read when Delphi first loads BDE and doesn't get re-read

Brian
--
Brian Bushay (TeamB)
Bbus...@DataGuidance.com

Other Threads