Board index » delphi » Interbase to Internet question

Interbase to Internet question

I want to use Interbase with my webserver. Connecting on a webmodule is
throwing an error. Am I going about this the right way.

Should I be using the TWebModule

Gary

 

Re:Interbase to Internet question


Please be more specific (what message error, witch OS, witch IB version,
witch http server, etc) when asking for support.

I guess that the error you have is because when you use web connections you
can't do it with local protocol (<drive>:\<path to database>), you must
connect via TCP/IP:

    localhost:<drive>:\<path to database>

or

    <servername>:<drive>:\<path to database>

--
Sergio Samayoa
Lgica Software
http://www.geocities.com/logicasw/

"Gary Haywood" <g...@datasystems.com.au> escribi en el mensaje
news:3b4a7145$2_1@dnews...

Quote
> I want to use Interbase with my webserver. Connecting on a webmodule is
> throwing an error. Am I going about this the right way.

> Should I be using the TWebModule

> Gary

Re:Interbase to Internet question


The Interbase Server (6.01) is on the same machine as the IIS (Microsoft
IIS5) and I have a Web Server Application (ISAPI). The WebServer Application
is attempting to connect thru the local protocol because the database is on
the same machine. The error is "unavailable database" which you would get if
the database server wasn't running.

Thanks for your reply I will now attempt to connect via tcp/ip

Gary

Quote
"Sergio Samayoa" <serg...@terra.com.gt> wrote in message

news:3b4a721e_2@dnews...
Quote
> Please be more specific (what message error, witch OS, witch IB version,
> witch http server, etc) when asking for support.

> I guess that the error you have is because when you use web connections
you
> can't do it with local protocol (<drive>:\<path to database>), you must
> connect via TCP/IP:

>     localhost:<drive>:\<path to database>

> or

>     <servername>:<drive>:\<path to database>

> --
> Sergio Samayoa
> Lgica Software
> http://www.geocities.com/logicasw/

> "Gary Haywood" <g...@datasystems.com.au> escribi en el mensaje
> news:3b4a7145$2_1@dnews...
> > I want to use Interbase with my webserver. Connecting on a webmodule is
> > throwing an error. Am I going about this the right way.

> > Should I be using the TWebModule

> > Gary

Re:Interbase to Internet question


Thanks again

It runs when the connection is made via tcp/ip

Gary

Quote
"Sergio Samayoa" <serg...@terra.com.gt> wrote in message

news:3b4a721e_2@dnews...
Quote
> Please be more specific (what message error, witch OS, witch IB version,
> witch http server, etc) when asking for support.

> I guess that the error you have is because when you use web connections
you
> can't do it with local protocol (<drive>:\<path to database>), you must
> connect via TCP/IP:

>     localhost:<drive>:\<path to database>

> or

>     <servername>:<drive>:\<path to database>

> --
> Sergio Samayoa
> Lgica Software
> http://www.geocities.com/logicasw/

> "Gary Haywood" <g...@datasystems.com.au> escribi en el mensaje
> news:3b4a7145$2_1@dnews...
> > I want to use Interbase with my webserver. Connecting on a webmodule is
> > throwing an error. Am I going about this the right way.

> > Should I be using the TWebModule

> > Gary

Other Threads