Board index » delphi » Delphi4: Mediaplayer and CDAudio problem

Delphi4: Mediaplayer and CDAudio problem

Hello,

in a project I'm trying to play a CD audio with the mediaplayer.
In Delphi 2 this worked with out much problems, but now in Delphi 4 the command
Mediaplayer1.Open I get an error telling me that it's unable to play the CD
because it might be damaged or in the wrong format. The Windows CD player will
play the CD only a few seconds later.

Does anyone have a solution for this problem?

Regards,

Arjan
=========================================================
Arjan van de Logt author of Yer Winlogo and other utils.
E-mail Arjan_van_de_L...@wxs.nl

Quote
>(Replace all underscores [_] with dots [.] to reply!!!)

http://www.tomb.demon.nl
=========================================================
 

Re:Delphi4: Mediaplayer and CDAudio problem


In article <35fa6593.1254...@news.wxs.nl>, Arjan
<Arjan_van_de_L...@wxs.nl> writes

Quote
>Hello,

>in a project I'm trying to play a CD audio with the mediaplayer.
>In Delphi 2 this worked with out much problems, but now in Delphi 4 the command
>Mediaplayer1.Open I get an error telling me that it's unable to play the CD
>because it might be damaged or in the wrong format. The Windows CD player will
>play the CD only a few seconds later.

>Does anyone have a solution for this problem?

>Regards,

>Arjan
>=========================================================
>Arjan van de Logt author of Yer Winlogo and other utils.
>E-mail Arjan_van_de_L...@wxs.nl
>>(Replace all underscores [_] with dots [.] to reply!!!)
>http://www.tomb.demon.nl
>=========================================================

I had the same problem after upgrading to Delphi 4 and adding a CD
writer.  I am not sure whether the problem was caused by having two CD
ROM drives or by the change to Delphi 4.

The solution was to set MediaPlayer1.FileName to the drive letter of the
CD ROM drive to be used (In my case MediaPlayer1.FileName := 'E:';).

Hope this helps.
--
John Wright

Re:Delphi4: Mediaplayer and CDAudio problem


On Sat, 12 Sep 1998 00:03:51 +0100, John Wright <j...@johnwright.demon.co.uk>
wrote:

Quote
>I had the same problem after upgrading to Delphi 4 and adding a CD
>writer.  I am not sure whether the problem was caused by having two CD
>ROM drives or by the change to Delphi 4.

>The solution was to set MediaPlayer1.FileName to the drive letter of the
>CD ROM drive to be used (In my case MediaPlayer1.FileName := 'E:';).

Hello,

My problem occured only with one CD-ROM. I think that setting the driveletter
will do here also. Thanks.

Arjan
=========================================================
Arjan van de Logt author of Yer Winlogo and other utils.
E-mail Arjan_van_de_L...@wxs.nl

Quote
>(Replace all underscores [_] with dots [.] to reply!!!)

http://www.tomb.demon.nl
=========================================================

Other Threads