Board index » delphi » Speed degredation - Ado - SQL Server7

Speed degredation - Ado - SQL Server7

Hi
I have a speed degradation issue with Ado Express and Sql Server 7 using
Server side cursors. My app starts up fast and runs well for a while, then
after a  while my queries start executing slower and slower. I suspect that
the connection may even be lost in some cases. The funny thnig is that this
is totally random. After the query timed out the first time, it will work
fine for a while after that and then start timing out again, and so on. This
problem only started since I changed my cursorlocation to clUseServer. My
connection properties are as follows:
IsolationLevel : ilCurorstability
Mode : cmShareDenyNone
CursorLocation: clUseServer

Riaan Gouws

 

Re:Speed degredation - Ado - SQL Server7


How about the locking?

Re:Speed degredation - Ado - SQL Server7


I have tried any and every type of read only locking - I've even specified
locking hints in the sql statement itself - nolock, readpast,etc.....
The problem sorts itself out when I bypass the TAdoQuery object and work
directly with ado's _Recordset object . In fact, it's a lot faster when I
use the _Recordset object directly. But my project is far to big and complex
to start using _Recordset obects instead of TAdoQueries. Is there any other
solutuion ?

Riaan Gouws

Quote
"Alessandro Federici" <a...@bigfoot.com> wrote in message

news:8t5qcu$t2q9@bornews.borland.com...
Quote
> How about the locking?

Other Threads