Board index » delphi » Crystal reports, D6, and SQL Error 599

Crystal reports, D6, and SQL Error 599

Hi,

I have been having some real wierd problems with Crystal 8.5, D6, and W2k.
I can create a report and have it work initially from my Delphi app.  If I
then go out and add a couple of fields from a table that is already there,
or make some other seemingly insiginificant changes I will often get back a
Error 599 (cannot open SQL server) message, and cannot get it to work again.

I would appreciate any suggestions from others with any similar experinces.

Thanks!

 

Re:Crystal reports, D6, and SQL Error 599


Quote
"Russ Vogel" <russ_vo...@alltel.net> wrote...
> I have been having some real wierd problems with Crystal 8.5, D6, and W2k.
> I can create a report and have it work initially from my Delphi app.  If I
> then go out and add a couple of fields from a table that is already there,
> or make some other seemingly insiginificant changes I will often get back a
> Error 599 (cannot open SQL server) message, and cannot get it to work again.

You don't specify which database you are connecting to, nor whether you're
using Active Data reports or direct database access via Crystal's drivers
instead of Delphi's.

If you are connecting directly to an SQL server like MS SQL Server or Oracle,
it's quite possible that you need to explicitly go into the report in Crystal,
do a Database | Log On Server, and Database | Verify Database before saving
the report and accessing it again with Delphi.  Skipping the Database | Log On
Server can cause weird things to happen.
--
-Brion
Team JEDI, 2001 Spirit of Delphi Award Winners
http://www.delphi-jedi.org
Fresno Area Delphi Users Group
http://groups.yahoo.com/group/FresnoDelphi

Other Threads