Board index » delphi » MSACCESS: Problems with AutoInc-Field, Type: Replication-ID

MSACCESS: Problems with AutoInc-Field, Type: Replication-ID

I want to use the replication-feature in MS-Access to keep a database in
sync at three companys.
So I use auto-incremented replication-IDs as my index-fields in
Access97.
Here is what D3 did so far:
- D3.0 didn't see the fields at all (for example in table's
field-editor)
- D3.01 + BDE4.51 saw them (as TBytesField), but a
master-detail-relationship between two tables only resulted in funny
dbgrid-jumps and didn't work as it should
- no changes in D3.02
- BDE5.01 doesn't see the fields at all... (back to the roots)

so - HELP!!!! please...

Marc

 

Re:MSACCESS: Problems with AutoInc-Field, Type: Replication-ID


In article <36AE0BA2.9FFD5...@only.de>,
  Marc Noske <ma...@only.de> wrote:

Quote
> I want to use the replication-feature in MS-Access to keep a database in
> sync at three companys.
> So I use auto-incremented replication-IDs as my index-fields in
> Access97.
> Here is what D3 did so far:
> - D3.0 didn't see the fields at all (for example in table's
> field-editor)
> - D3.01 + BDE4.51 saw them (as TBytesField), but a
> master-detail-relationship between two tables only resulted in funny
> dbgrid-jumps and didn't work as it should
> - no changes in D3.02
> - BDE5.01 doesn't see the fields at all... (back to the roots)

> so - HELP!!!! please...

> Marc

    The problem might be that you are using the wrong driver for MSaccess try
using ODBC I proved that feature and I did not have problem, good luck.
Mike

-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own    

Other Threads