Board index » delphi » StoredProc parameters not changing

StoredProc parameters not changing

Hi,

I have several TADODataSets connected to Access 2000 storedprocs which use
input parameters. When I initialize the TADODataSet it returns a result set
but when I change a parameter and requery the same result set is returned.
It appears the the value of the parameters are not being updated. Is there
something else I have to call before changing the parameter and calling
requery to reinitialize the parameters?
thanks, Paul

 

Re:StoredProc parameters not changing


The problem with stored procedures in ADO with Delphi and Access2000 is very
serious. We found only one work-around:
Discard the query (ProcedureName) and the parameters.  Then reassign the
ProcedureName, the parameters and then the (new) values of the parameters.
After that You can re-execute the stored procedure. I'm not sure, whether
this behaviour comes from wrong implementation in Delphi or from a bug in
ADO / Access2000.

If someone has more information concerning the "stored procedure" bug I
would like him or her to send this information to me.
Otto

Paul Gavin <pa...@productivesolutions.com.au> schrieb in im Newsbeitrag:
8db5v9$a...@bornews.borland.com...

Quote
> Hi,

> I have several TADODataSets connected to Access 2000 storedprocs which use
> input parameters. When I initialize the TADODataSet it returns a result
set
> but when I change a parameter and requery the same result set is returned.
> It appears the the value of the parameters are not being updated. Is there
> something else I have to call before changing the parameter and calling
> requery to reinitialize the parameters?

> thanks, Paul

Other Threads