Board index » delphi » "Invalid Blob handle in record buffer"-error PLEASE HELP

"Invalid Blob handle in record buffer"-error PLEASE HELP

Hi All

Can anyone please help me. I have a Query Object (Delphi4 C/S) which select
a SQL-Server7 Table with 2 text (Blob) fields. RequestLive is set to true.
When I post a new record with data in the 2 blob fields I get the error
"Invalid Blob handle in record buffer". I've set Blobs to Cache in BDE to
65535(Max)

What can I do to avoid this error

regards
Chris Viljoen
Skysoft

 

Re:"Invalid Blob handle in record buffer"-error PLEASE HELP


I don't know that this is still true, but at some versions of Delphi
I recall that you had to use Cached Updates with BLOBS instead of
Request Live.
Quote
Chris Viljoen wrote:

> Hi All

> Can anyone please help me. I have a Query Object (Delphi4 C/S) which select
> a SQL-Server7 Table with 2 text (Blob) fields. RequestLive is set to true.
> When I post a new record with data in the 2 blob fields I get the error
> "Invalid Blob handle in record buffer". I've set Blobs to Cache in BDE to
> 65535(Max)

> What can I do to avoid this error

> regards
> Chris Viljoen
> Skysoft

Re:"Invalid Blob handle in record buffer"-error PLEASE HELP


Re:"Invalid Blob handle in record buffer"-error PLEASE HELP


Hi,

you have to set the BLOB SIZE parameter to a high value (ex. 1000), the
BLOBS TO CACHE meens the number of cached records (for the blob part).
Sometimes the problem could also be resolved in posting the changes to text
(blob) fields with a separate post. So do first do INSERT of the record with
non blob-fields, then put it in edit-mode, assign the blob-data and redo the
post.

hope this helps

Anton Santa

Quote
Chris Viljoen <C...@skysoft.co.za> wrote in message 3a3623ae_1@dnews...
> Hi All

> Can anyone please help me. I have a Query Object (Delphi4 C/S) which
select
> a SQL-Server7 Table with 2 text (Blob) fields. RequestLive is set to true.
> When I post a new record with data in the 2 blob fields I get the error
> "Invalid Blob handle in record buffer". I've set Blobs to Cache in BDE to
> 65535(Max)

> What can I do to avoid this error

> regards
> Chris Viljoen
> Skysoft

Other Threads