Board index » delphi » HELP: Out of System Resources with BDE

HELP: Out of System Resources with BDE

Try compiling your app under Windows. I have had a similar problem and it
went away when I compiled the app under Windows 3.1.

Joha Kotze

Quote
> late...@global.co.za (Craig Mason-Jones) wrote in article

<4pm5b1$...@dodo.global.co.za>...
Quote
> Hi, Help Please:
> I've created a little app in Delphi 1.0 that uses the BDE to manage a
> small database. It works fine under Windows 95, but I need to run it
> on Windows 3.1 platforms with 8MB ram. The problem is, whenever I do
> so, I get Out of System Resource errors all the time (especially when
> I try to create new forms). I know I'm not out of System Resources, A)
> because I've been through the code 100 times, and B) because I've a
> little window that tells me I have over 80% free system resources.
> Does anyone have any idea what might be generating this error under
> Windows 3.1, and _especially_, what I can do about it?
> Thanks in advance,
> Craig

 

Re:HELP: Out of System Resources with BDE


Hi, Help Please:
I've created a little app in Delphi 1.0 that uses the BDE to manage a
small database. It works fine under Windows 95, but I need to run it
on Windows 3.1 platforms with 8MB ram. The problem is, whenever I do
so, I get Out of System Resource errors all the time (especially when
I try to create new forms). I know I'm not out of System Resources, A)
because I've been through the code 100 times, and B) because I've a
little window that tells me I have over 80% free system resources.
Does anyone have any idea what might be generating this error under
Windows 3.1, and _especially_, what I can do about it?
Thanks in advance,
Craig

Re:HELP: Out of System Resources with BDE


Why not go native ODBC datatbase  connectivity?
Check out the ODBC Express site at http://www.adam.co.za.

Roger Weiss
(rog...@iafrica.com)
South Africa

Re:HELP: Out of System Resources with BDE


la>I've created a little app in Delphi 1.0 that uses the BDE to manage a
la>small database. It works fine under Windows 95, but I need to run it
la>on Windows 3.1 platforms with 8MB ram. The problem is, whenever I do
la>so, I get Out of System Resource errors all the time (especially when
la>I try to create new forms). I know I'm not out of System Resources, A)
la>because I've been through the code 100 times, and B) because I've a
la>little window that tells me I have over 80% free system resources.
la>Does anyone have any idea what might be generating this error under
la>Windows 3.1, and _especially_, what I can do about it?

Try removing any glyphs you might have on TBitBtns and such. Or check if there
is a newer display driver available for your 8mb machine. I had exactly the
same symptoms in a small program of mine; removing the glyphs I used on the
form that blew up fixed the problem.

--
Mr. HillBilly (hillbi...@programmers.bbs.no)
Programmers BBS er oppe igjen, n? p? tlf. 22217666/22217669!
 tHyperSoft HyperReader 1.0t

Other Threads