Board index » delphi » Delphi5, MDAC 2.5 and ADOUpdate2

Delphi5, MDAC 2.5 and ADOUpdate2

Hello,

For the problem "Either EOF or BOF true..." which is due to the MDAC version
update from 2.5 to 2.6 or 2.7 it is suggested to do the ADOUpdate2 and it
will work.

I have Delphi5, I applied the update and recompiled everything, but the
error remains.

What may be the problem? Maybe okay for MDAC 2.6 but not for 2.7?

Thanks,

Charlie

 

Re:Delphi5, MDAC 2.5 and ADOUpdate2


Quote
"Karoly Horvath" <Karoly.Horv...@sbcglobal.net> wrote in message

news:3e599ecb$1@newsgroups.borland.com...
Quote
> For the problem "Either EOF or BOF true..." which is due to the MDAC
version
> update from 2.5 to 2.6 or 2.7 it is suggested to do the ADOUpdate2 and it
> will work.
> I have Delphi5, I applied the update and recompiled everything, but the
> error remains.

D5 Upd#1 and Ado Upd#2 both must be installed.

Re:Delphi5, MDAC 2.5 and ADOUpdate2


Hi!

I have the same problem. Is it possible to fix the problem without
re-compiling? I don't have the source code!

J.T.

Re:Delphi5, MDAC 2.5 and ADOUpdate2


That's right, I cannot even install ADOUpdate2 without inbstalling SP1
first. That's what I did, but I receive the error.

Quote
"Andrew Ryazanov" <r...@land.ru> wrote in message

news:3e59ef76@newsgroups.borland.com...
Quote
> "Karoly Horvath" <Karoly.Horv...@sbcglobal.net> wrote in message
> news:3e599ecb$1@newsgroups.borland.com...
> > For the problem "Either EOF or BOF true..." which is due to the MDAC
> version
> > update from 2.5 to 2.6 or 2.7 it is suggested to do the ADOUpdate2 and
it
> > will work.
> > I have Delphi5, I applied the update and recompiled everything, but the
> > error remains.
> D5 Upd#1 and Ado Upd#2 both must be installed.

Re:Delphi5, MDAC 2.5 and ADOUpdate2


Quote
>I have Delphi5, I applied the update and recompiled everything, but the
>error remains.

>What may be the problem? Maybe okay for MDAC 2.6 but not for 2.7?

There are probably copies of the old version of ADODB.dcu in some of your
directories.
or you are only getting this error when you run from the IDE which is something
you can ignore.
--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Other Threads