Board index » delphi » SQL Server 7.0 with Delphi 5.0 - stored procedures with parameters - Native BDE driver

SQL Server 7.0 with Delphi 5.0 - stored procedures with parameters - Native BDE driver

Hi,

I am using SQL Server 7.0 on Windows NT server 4.0 with SP5. On the client
side, I am using Delphi 5.0 Enterprise.
I have the BDE version 5.01.

On the server side, I have a stored procedure Proc1  which has an input
parameter @param1.
On the client side, I have a TStoredProc with the storedprocname as proc1
and I have defined the
parameter's properties defined properly.

Now, all is fine if I use the Microsoft ODBC driver. However, if I use the
native Borland supplied BDE driver (MSSQL), then I get an error 'cannot find
stored procedure proc1' on making the TStoredProc active.

If I use a TQuery with the strings property as 'exec proc1 1234' then again
all is fine.

Can anyone help me please ?

Thanks in advance.

Kashi

 

Re:SQL Server 7.0 with Delphi 5.0 - stored procedures with parameters - Native BDE driver


Kashi,

   Remove the ;1 in your TStoredProc's StoredProcName property in the Object
Inspector.

Check out:
http://community.borland.com/article/0,1410,20590,00.html

Good luck,
krf

Quote
Kashinath wrote in message <93ksl3$h...@bornews.inprise.com>...
>Hi,

>I am using SQL Server 7.0 on Windows NT server 4.0 with SP5. On the client
>side, I am using Delphi 5.0 Enterprise.
>I have the BDE version 5.01.

>On the server side, I have a stored procedure Proc1  which has an input
>parameter @param1.
>On the client side, I have a TStoredProc with the storedprocname as proc1
>and I have defined the
>parameter's properties defined properly.

>Now, all is fine if I use the Microsoft ODBC driver. However, if I use the
>native Borland supplied BDE driver (MSSQL), then I get an error 'cannot
find
>stored procedure proc1' on making the TStoredProc active.

>If I use a TQuery with the strings property as 'exec proc1 1234' then again
>all is fine.

>Can anyone help me please ?

>Thanks in advance.

>Kashi

Re:SQL Server 7.0 with Delphi 5.0 - stored procedures with parameters - Native BDE driver


Remove ;1 from the stored procedure name.

Alex

Quote
"Kashinath" <rkka...@vsnl.com> wrote in message

news:93ksl3$hfo1@bornews.inprise.com...
Quote
> Now, all is fine if I use the Microsoft ODBC driver. However, if I use the
> native Borland supplied BDE driver (MSSQL), then I get an error 'cannot
find
> stored procedure proc1' on making the TStoredProc active.

Other Threads