Board index » delphi » BDE problems with new version of Windows 95 (R2)

BDE problems with new version of Windows 95 (R2)

I've been using Delphi for a while (currently Delphi 2 Developper french
version) and everything was OK. However, I upgraded my computer some weeks
ago and I encounter now some strange problems when working with database
applications:

1) It is impossible to run any database application (like the demos) as I
get a message 'Nom de fichier incorrect' ('Incorrect filename') when I try
to open the database using a TTable (at design-time or at run-time). Note
that the database is correctly 'seen' in the object inspector and that it
is possible to open it in Database Desktop.

I made some tests and it seems to me that this error occurs when there's a
space in the path where the files are located on my hard disk (like between
'Program' and 'Files' in 'Program Files'). So I put all the data files in a
different location where there is no space in the path ...

2) I discovered another problem when I tried to work with a Tquery: when I
try to put the active property to true in the object inspector, I get the
message 'Paramtre incorrect' ('Incorrect parameter'). More surprising,
this problem occurs only with Dbase (*.dbf) tables not with Paradox ones!

For example, if I use the DBDEMOS alias:

        with 'select * from animals': it doesn't work.

        with 'select * from customer': everything is OK.

        The main difference in the upgrade of my computer is that I got a 'new'
version of Windows 95 (OSR2 which comes with Internet Explorer 3 and can
manage disks of more that 2 Go) but I don't see why it could modify the way
the BDE works ...

        I would like to know if someone encountered the same problems and  has a
solution to them.

Thanks in advance.

eMail: cbeau...@club-internet.fr

 

Re:BDE problems with new version of Windows 95 (R2)


FAT32 formatting maby... Download the latest BDE disks (3,5) from
www.borland.com and your problem should be taken care of.

Re:BDE problems with new version of Windows 95 (R2)


I had similar problems, but the new 3.5 BDE seemed to solve them.  Have
you downloaded and installed that? (Avail on www.borland.com/delphi )

Cass

In article <01bc4c33$b421fa60$LocalHost@arthur>, cbeaurez@club-
internet.fr says...

Quote
> I've been using Delphi for a while (currently Delphi 2 ..
>    The main difference in the upgrade of my computer is that I got a 'new'
> version of Windows 95 (OSR2 which comes with Internet Explorer 3 and can
> manage disks of more that 2 Go) but I don't see why it could modify the way
> the BDE works ...

>    I would like to know if someone encountered the same problems and  has a
> solution to them.

> Thanks in advance.

> eMail: cbeau...@club-internet.fr

Re:BDE problems with new version of Windows 95 (R2)


Do not use long file names if you have BDE version prior to 3.5.

On 18 Apr 1997 20:06:03 GMT, "Christian Beaurez" <cbeau...@club-internet.fr>
wrote:

     I've been using Delphi for a while (currently Delphi 2 Developper french
     version) and everything was OK. However, I upgraded my computer some weeks
     ago and I encounter now some strange problems when working with database
     applications:

     1) It is impossible to run any database application (like the demos) as I
     get a message 'Nom de fichier incorrect' ('Incorrect filename') when I try
     to open the database using a TTable (at design-time or at run-time). Note
     that the database is correctly 'seen' in the object inspector and that it
     is possible to open it in Database Desktop.

     I made some tests and it seems to me that this error occurs when there's a
     space in the path where the files are located on my hard disk (like between
     'Program' and 'Files' in 'Program Files'). So I put all the data files in a
     different location where there is no space in the path ...

     2) I discovered another problem when I tried to work with a Tquery: when I
     try to put the active property to true in the object inspector, I get the
     message 'Paramtre incorrect' ('Incorrect parameter'). More surprising,
     this problem occurs only with Dbase (*.dbf) tables not with Paradox ones!

     For example, if I use the DBDEMOS alias:

        with 'select * from animals': it doesn't work.

        with 'select * from customer': everything is OK.

        The main difference in the upgrade of my computer is that I got a
'new'
     version of Windows 95 (OSR2 which comes with Internet Explorer 3 and can
     manage disks of more that 2 Go) but I don't see why it could modify the way
     the BDE works ...

        I would like to know if someone encountered the same problems and  has
a
     solution to them.

     Thanks in advance.

     eMail: cbeau...@club-internet.fr

       \\\|///
      \\ _ _ //
       ( @ @ )
+---o00o-(_)-o00o----------------------------+
| Branko Starasinic                          |
|                                            |
| Snail-mail:    Danfoss Compressors d.o.o.  |
|                Heroja Starihe 24           |
|                8340 Crnomelj               |
|                Slovenija                   |
| tel.:          +00386 68 51 400            |
|                                            |
| E-mail: branko.starasi...@danfoss-cmpr.si  |
+------------Oooo----------------------------+
      oooO  (   )
      (   )  ) /
       \ (   (_)
        \_)

Other Threads