Board index » delphi » Help! error 70 unit version mismatch on DBCtrls and DBtables

Help! error 70 unit version mismatch on DBCtrls and DBtables

I bought delphi 1.0 over a year ago uptil now Ive been writing non
database applications with no problems.

However I tried to create a simple database application using
a paradox table and I got the dreaded error 70.

Thinking that perhaps the delphi patch had screwed up delphi
I reinstalled delphi from CD and still got the same error.

Im going to try and get a hold of the VCL source code
(If borland still sells it)

Spookily though the demo databse aplications that come
with dephi work do compile... well so I though until
I realised that they came with the dcu's intact.

What do I do?

 

Re:Help! error 70 unit version mismatch on DBCtrls and DBtables


Quote
>However I tried to create a simple database application using
>a paradox table and I got the dreaded error 70.
>Thinking that perhaps the delphi patch had screwed up delphi
>I reinstalled delphi from CD and still got the same error.
>What do I do?

Learn compiler-speak.. I've grasped the fundamentals, when
delphi says

"Error 70: Unit Version Mismatch"

running a sophisticated english<>compiler language
phrase converter on the following

Quote
>A unit used by this project was compiled with an earlier version of the compiler.
>Make sure the source file for  the specified unit is on the compiler search path,
>then use Compile|Build All to automatically recompile the units that have changed.
>If you don't have the source file for the offending DCU unit,
>contact the author of the unit for an update.

resulted in

Quote
> You damn fool you. You're program is called DB, how d'you expect me
> to tell the difference between your program and db.dcu? Hey?
> Change the name at once and dont you be doing that stuff
> no more.

Crisis is temporarily over.

Other Threads