Board index » delphi » Error in TImage during design time

Error in TImage during design time

During design time, I am experiencing an error when loading a bitmap into a
TImage comonent.  When I double click the component and then click Load, it
brings up the open dialog.  Some .bmp files produce an error message:
"Stream read error".  There is no further information.

I am using Delphi 4 with the latest patch (I think) applied.

Any clues?

Chris

 

Re:Error in TImage during design time


I can read the file in Paint.  If I change one pixel and then save the file,
Delphi can read it properly.  Apparently, Delphi is picky about the .bmp
headers or else the program I used to create or convert the .bmp file is at
fault.

Thanks for the hints.

Peter Below (TeamB) <100113.1...@compuXXserve.com> wrote in message
news:VA.00003861.01768e2f@noname...

Quote
> > During design time, I am experiencing an error when loading a bitmap
into a
> > TImage comonent.  When I double click the component and then click Load,
it
> > brings up the open dialog.  Some .bmp files produce an error message:
> > "Stream read error".  There is no further information.

> > I am using Delphi 4 with the latest patch (I think) applied.

> > Any clues?

> Chris,

> can you view the bitmaps in MS Paint or Paintbrush? This message usually
> results from a file that has been corrupted somehow. If you use the Delphi
1
> or 2 ImageEditor to create bitmaps, better use Paintbrush, these versions
had
> some problems...

> Peter Below (TeamB)  100113.1...@compuserve.com)
> No e-mail responses, please, unless explicitly requested!

Other Threads