Board index » delphi » ADO returning wrong field types with Oracle table

ADO returning wrong field types with Oracle table

I am using Delphi 6 (Update pack 2) with ADO components.  I'm using the
TADOTable to connect to a small table in an oracle 8i database with three
fields.  When I add all fields with the field editor, it adds the fields,
but two of the three fields have the wrong type; my oracle table has these
fields: Long, Varchar2, and integer but when added in the field editor in
Delphi they come in as TMemoField, TStringField (This is the correct one),
and TBCDField.  Anybody know what is going on?  Using ADO instead of BDE is
new to me so perhaps I'm overlooking something.
 

Re:ADO returning wrong field types with Oracle table


Ther is a problem in ADODB.pas, we have modified the line and all is ok for
us. We have made a new component too in order to have design time
functionning, if you want this email me.

Luc Bellego
lbell...@gbinaire.com
Directeur du service informatique
Cognicase, Gestion Binaire Inc.

"Mark Grover" <mark.gro...@seaquistperfect.com> a crit dans le message de
news: 3cea59bf$1_1@dnews...

Quote
> I am using Delphi 6 (Update pack 2) with ADO components.  I'm using the
> TADOTable to connect to a small table in an oracle 8i database with three
> fields.  When I add all fields with the field editor, it adds the fields,
> but two of the three fields have the wrong type; my oracle table has these
> fields: Long, Varchar2, and integer but when added in the field editor in
> Delphi they come in as TMemoField, TStringField (This is the correct one),
> and TBCDField.  Anybody know what is going on?  Using ADO instead of BDE
is
> new to me so perhaps I'm overlooking something.

Other Threads