Board index » delphi » Access violation errors with Quick Reports

Access violation errors with Quick Reports

I am trying to use quickreports in my application, but I keep getting Access
violation errors.  In one of my apps I have to force close Delphi to get the
debug session to stop.  Has anyone had any of theres problems that could
help?  BTW, I am using Delphi 4 and the QuickReports components that comes
with Delphi 4 which are version 3, I think.
 

Re:Access violation errors with Quick Reports


Try :

Application.ProcessMessages

 after preview.

Carlos Domingues
----------------------------------------------

Quote
"Joel Hughes" <jo...@moves.com> wrote in message news:3a830962$1_1@dnews...
> I am trying to use quickreports in my application, but I keep getting
Access
> violation errors.  In one of my apps I have to force close Delphi to get
the
> debug session to stop.  Has anyone had any of theres problems that could
> help?  BTW, I am using Delphi 4 and the QuickReports components that comes
> with Delphi 4 which are version 3, I think.

Re:Access violation errors with Quick Reports


I have the same problems, sometimes it say's something like 'A component by that
name already exists'. Or it just crashes during the preview mode.

It's one of the reasons I realy hate to make programs including Qrapport,
customers blame me you see :(.

If you find any solutions please post it here or mail me.

I realy hope these isues are over in Delphi 6 wich I plan to buy next (Have D4
Standard now)

Quote
Joel Hughes wrote:
> I am trying to use quickreports in my application, but I keep getting Access
> violation errors.  In one of my apps I have to force close Delphi to get the
> debug session to stop.  Has anyone had any of theres problems that could
> help?  BTW, I am using Delphi 4 and the QuickReports components that comes
> with Delphi 4 which are version 3, I think.

Other Threads