Board index » delphi » RTE 200 question

RTE 200 question

On WHICH computers does the RTE200 bug of CRT occur? I read the FAQ, which
says: P2-233 and up I have an AMD K6-2 350, but RTE200 does NOT occur. Why?
Is my computer not ok? Cache defective? BIOS settings? Or just other
instruction timing?

-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own    

 

Re:RTE 200 question


Quote
> On WHICH computers does the RTE200 bug of CRT occur? I read the FAQ, which
> says: P2-233 and up I have an AMD K6-2 350, but RTE200 does NOT occur. Why?
> Is my computer not ok? Cache defective? BIOS settings? Or just other
> instruction timing?

   It (generally) starts to occur when the speed of the processor
(whichever type it is) >= 200mhz.  I have a 200mhz laptop on which it
doesn't occur, but I have heard many who have only 200mhz working for
them encounter the problem.  It may have something to do which the
operating system being used (where pure DOS execution exhibits it), but
the same computer running Windows* may not - because of some extra
overhead processing which is stolen from the application.  So, 200mhz is
"iffy", I think.
   And it occurs only because the speed of executing a certain loop of
instructions (to determine the amount code needed to help the Delay
procedure do it's work) causes it to run too fast and produce a 0 sum
from it - which is then used in a subsequent divide instruction.  It's a
simple bug, caused by insufficient design to accommodate the faster
processors which were yet to come... 8<}}

Re:RTE 200 question


In article <MPG.113a9265ad3f43f0989...@news.primenet.com>,
Quote
Mike Copeland <mrc...@primenet.com> wrote:

:   It (generally) starts to occur when the speed of the processor
:(whichever type it is) >= 200mhz.  I have a 200mhz laptop on which it

:overhead processing which is stolen from the application.  So, 200mhz is
:"iffy", I think.

True. I have encountered this problem even on a 150MHz about 1 times
out of 100-1000 when run in the plain MS-DOS mode.

   All the best, Timo

....................................................................
Prof. Timo Salmi   Co-moderator of news:comp.archives.msdos.announce
Moderating at ftp:// & http://garbo.uwasa.fi/ archives 193.166.120.5
Department of Accounting and Business Finance  ; University of Vaasa
mailto:t...@uwasa.fi <http://www.uwasa.fi/~ts/>  ; FIN-65101,  Finland

Spam foiling in effect.  My email filter autoresponder will return a
required email password to users not yet in the privileges database.
Advice on spam foiling at http://www.uwasa.fi/~ts/info/spamfoil.html

Other Threads