Board index » delphi » Unknow EDBEngineError on a paradox table.

Unknow EDBEngineError on a paradox table.

Hi,
I have a problem with a paradox table.
My table stay opened quite a long time during the execution of the
program.
This table is placed on another computer on the network.
And sometime  I got the error:

EDBEngineError
    Erreur interne systme d'exploitation inconnue.
    Mauvais numro de fichier.
    Fichier: E:\Database\MyTable.DB

in English:   (this is a translation, so the real error message can be
different)
EDBEngineError
    Unknow internal operating system error.
    Wrong file number.
    File: E:\Database\MyTable.DB

E: is the network drive.

Thanks for your help.

            Olyv

PS: Sorry for my poor english.

 

Re:Unknow EDBEngineError on a paradox table.


The description is not completely clear. Are you USING the table on network
drive or are you COPYING the table to a network drive.
If you are copying the table make sure the table is closed while copying.
If you are using a table on a network drive you should read the tips on
http://www.bdesupport.com/stability.htm.

Quote
"Olivier PERAUDEAU" <operaud...@jes.fr> wrote in message

news:3C8F0FC8.50E51F9F@jes.fr...
Quote
> Hi,
> I have a problem with a paradox table.
> My table stay opened quite a long time during the execution of the
> program.
> This table is placed on another computer on the network.
> And sometime  I got the error:

> EDBEngineError
>     Erreur interne systme d'exploitation inconnue.
>     Mauvais numro de fichier.
>     Fichier: E:\Database\MyTable.DB

> in English:   (this is a translation, so the real error message can be
> different)
> EDBEngineError
>     Unknow internal operating system error.
>     Wrong file number.
>     File: E:\Database\MyTable.DB

> E: is the network drive.

> Thanks for your help.

>             Olyv

> PS: Sorry for my poor english.

Re:Unknow EDBEngineError on a paradox table.


I'm USING the table on the network.
And the app works is on W98.
in my BDEAdmin i havec LocalShare set to True.
It works on a BDE 4.51.

The web adress doesn't seems to help me about this.

"M.H. Avegaart" a crit :

Quote
> The description is not completely clear. Are you USING the table on network
> drive or are you COPYING the table to a network drive.
> If you are copying the table make sure the table is closed while copying.
> If you are using a table on a network drive you should read the tips on
> http://www.bdesupport.com/stability.htm.

> "Olivier PERAUDEAU" <operaud...@jes.fr> wrote in message
> news:3C8F0FC8.50E51F9F@jes.fr...
> > Hi,
> > I have a problem with a paradox table.
> > My table stay opened quite a long time during the execution of the
> > program.
> > This table is placed on another computer on the network.
> > And sometime  I got the error:

> > EDBEngineError
> >     Erreur interne systme d'exploitation inconnue.
> >     Mauvais numro de fichier.
> >     Fichier: E:\Database\MyTable.DB

> > in English:   (this is a translation, so the real error message can be
> > different)
> > EDBEngineError
> >     Unknow internal operating system error.
> >     Wrong file number.
> >     File: E:\Database\MyTable.DB

> > E: is the network drive.

> > Thanks for your help.

> >             Olyv

> > PS: Sorry for my poor english.

Re:Unknow EDBEngineError on a paradox table.


Quote
Olivier PERAUDEAU <operaud...@jes.fr> wrote in message

news:3C91F605.71340334@jes.fr...
| I'm USING the table on the network.
| And the app works is on W98.
| in my BDEAdmin i havec LocalShare set to True.
| It works on a BDE 4.51.
|
| The web adress doesn't seems to help me about this.

Sounds to me like a bad memory or other hardware
problem (check for overheating of the CPU), possibly
some software corrupting the BDE.

PR

|
|
| "M.H. Avegaart" a crit :
|
| > The description is not completely clear. Are you USING the table on
network
| > drive or are you COPYING the table to a network drive.
| > If you are copying the table make sure the table is closed while
copying.
| > If you are using a table on a network drive you should read the tips on
| > http://www.bdesupport.com/stability.htm.
| >
| > "Olivier PERAUDEAU" <operaud...@jes.fr> wrote in message
| > news:3C8F0FC8.50E51F9F@jes.fr...
| > > Hi,
| > > I have a problem with a paradox table.
| > > My table stay opened quite a long time during the execution of the
| > > program.
| > > This table is placed on another computer on the network.
| > > And sometime  I got the error:
| > >
| > > EDBEngineError
| > >     Erreur interne systme d'exploitation inconnue.
| > >     Mauvais numro de fichier.
| > >     Fichier: E:\Database\MyTable.DB
| > >
| > > in English:   (this is a translation, so the real error message can be
| > > different)
| > > EDBEngineError
| > >     Unknow internal operating system error.
| > >     Wrong file number.
| > >     File: E:\Database\MyTable.DB
| > >
| > > E: is the network drive.
| > >
| > >
| > > Thanks for your help.
| > >
| > >             Olyv
| > >
| > >
| > > PS: Sorry for my poor english.
| > >
| > >
| > >
|

Re:Unknow EDBEngineError on a paradox table.


????
I don't think it's a hardaware or memory problem.
But I've got another clue.
There's several programs which access this table
during the execution of my program.

peterr a crit :

Quote
> Olivier PERAUDEAU <operaud...@jes.fr> wrote in message
> news:3C91F605.71340334@jes.fr...
> | I'm USING the table on the network.
> | And the app works is on W98.
> | in my BDEAdmin i havec LocalShare set to True.
> | It works on a BDE 4.51.
> |
> | The web adress doesn't seems to help me about this.

> Sounds to me like a bad memory or other hardware
> problem (check for overheating of the CPU), possibly
> some software corrupting the BDE.

> PR

> |
> |
> | "M.H. Avegaart" a crit :
> |
> | > The description is not completely clear. Are you USING the table on
> network
> | > drive or are you COPYING the table to a network drive.
> | > If you are copying the table make sure the table is closed while
> copying.
> | > If you are using a table on a network drive you should read the tips on
> | > http://www.bdesupport.com/stability.htm.
> | >
> | > "Olivier PERAUDEAU" <operaud...@jes.fr> wrote in message
> | > news:3C8F0FC8.50E51F9F@jes.fr...
> | > > Hi,
> | > > I have a problem with a paradox table.
> | > > My table stay opened quite a long time during the execution of the
> | > > program.
> | > > This table is placed on another computer on the network.
> | > > And sometime  I got the error:
> | > >
> | > > EDBEngineError
> | > >     Erreur interne systme d'exploitation inconnue.
> | > >     Mauvais numro de fichier.
> | > >     Fichier: E:\Database\MyTable.DB
> | > >
> | > > in English:   (this is a translation, so the real error message can be
> | > > different)
> | > > EDBEngineError
> | > >     Unknow internal operating system error.
> | > >     Wrong file number.
> | > >     File: E:\Database\MyTable.DB
> | > >
> | > > E: is the network drive.
> | > >
> | > >
> | > > Thanks for your help.
> | > >
> | > >             Olyv
> | > >
> | > >
> | > > PS: Sorry for my poor english.
> | > >
> | > >
> | > >
> |

Other Threads