Board index » delphi » DELPHI 2.0 + MS-SQL6.0 - HANGS WITH POST OR INSERT

DELPHI 2.0 + MS-SQL6.0 - HANGS WITH POST OR INSERT

I'am using Delphi 2.0 for building an C/S application.
The server is MS-SQL 6.0 running on an P133 / 32MB machine.
The Clients all have 16MB Ram.

1. Sometimes the CLIENT application hangs when the user makes a change
or insertion to the database.
2. In the Database LOG I find : Error 17824 AND
   UNABLE TO WRITE TO LISTENON CONNECTION '\\.\PIPE\SQL\QUERY',...

What can be the reaseon ????

(PS In the past I got an answer saying it was the use of clustered
 indexes.  It wasn't a solution !)

The same problem occured with DELPHI 1.0.
When I use the SQL interface from Microsoft I don't hav a problem.

=============

Thanks for any ideas.

Peter De Ranter

 

Re:DELPHI 2.0 + MS-SQL6.0 - HANGS WITH POST OR INSERT


In article <317FD16A....@glo.be>, Peter De Ranter  <pete...@glo.be> wrote:

Quote
>I'am using Delphi 2.0 for building an C/S application.
>The server is MS-SQL 6.0 running on an P133 / 32MB machine.
>The Clients all have 16MB Ram.

>1. Sometimes the CLIENT application hangs when the user makes a change
>or insertion to the database.
>2. In the Database LOG I find : Error 17824 AND
>   UNABLE TO WRITE TO LISTENON CONNECTION '\\.\PIPE\SQL\QUERY',...

>What can be the reaseon ????

>(PS In the past I got an answer saying it was the use of clustered
> indexes.  It wasn't a solution !)

>The same problem occured with DELPHI 1.0.
>When I use the SQL interface from Microsoft I don't hav a problem.

I am having a similar problem, when it locks up and I go to the
"Current Activity" page in the SQL Enterprise Manager and double
click on the locked process, it shows some screwed up mangled SQL
statement that looks like part of the INSERT or UPDATE with some
extra {*word*99} thrown in.

Any assistance truly welcome here, too!

        - Brian G.

Other Threads