Board index » delphi » Can't connect to SQL Server 7 using NT Security using the BDE

Can't connect to SQL Server 7 using NT Security using the BDE

I get 'Unknown user name or password' when trying to connect to a SQL Server
7.0 database using Delphi 4.0 with BDE version 5.01.  I can connect using SA
as the user name but not when using my own ID.  I can connect to the
database using ISQl/W so it must be something with the BDE.  Any information
about this problem would be greatly appreciated.
 

Re:Can't connect to SQL Server 7 using NT Security using the BDE


has your user ID been setup in NT and SQL Server?  Does not sound like it.
Quote
Phil wrote:
> I get 'Unknown user name or password' when trying to connect to a SQL Server
> 7.0 database using Delphi 4.0 with BDE version 5.01.  I can connect using SA
> as the user name but not when using my own ID.  I can connect to the
> database using ISQl/W so it must be something with the BDE.  Any information
> about this problem would be greatly appreciated.

Re:Can't connect to SQL Server 7 using NT Security using the BDE


If you use nt security in SQL Server 6.5 you can use a space for the
username and no password and it will connect.  This will give you an error
in SQL Server 7 though.  You have to take the space out in this case.  When
you double click the TDatabase component, make sure there is no spaces after
the 'USERNAME=' line.

Re:Can't connect to SQL Server 7 using NT Security using the BDE


Phil,

Some things to check:

USER NAME must both be empty in the alias as well as the MSSQL driver.

PASSWORD must also be empty when you login.

You must have a login for yourself or a group that you are a member of (use
Enterprise Manager).

NT Authentication works with the 'Named Pipes' and 'Multiprotocol' protocols.
It does not work with TCP/IP (I am not sure about the others).

Make sure you can login to the Query Analyzer (ISQL) using NT authentication
before looking to the BDE for a problem.

HTH,

Jim

Quote
Phil wrote:
> I get 'Unknown user name or password' when trying to connect to a SQL Server
> 7.0 database using Delphi 4.0 with BDE version 5.01.  I can connect using SA
> as the user name but not when using my own ID.  I can connect to the
> database using ISQl/W so it must be something with the BDE.  Any information
> about this problem would be greatly appreciated.

Re:Can't connect to SQL Server 7 using NT Security using the BDE


Re:Can't connect to SQL Server 7 using NT Security using the BDE


Thank you very much!

I had to blank out the username under Configuration-Drivers-Native-MSSQL to
get connected.  I don't know if I would have found that on my own.  Thats
not something I had to do under 6.5.  Thanks again.

Phil

Quote
Jim Elden wrote in message <37382691.979B3...@nospam.accumedic.com>...
>Phil,

>Some things to check:

>USER NAME must both be empty in the alias as well as the MSSQL driver.

>PASSWORD must also be empty when you login.

>You must have a login for yourself or a group that you are a member of (use
>Enterprise Manager).

>NT Authentication works with the 'Named Pipes' and 'Multiprotocol'
protocols.
>It does not work with TCP/IP (I am not sure about the others).

>Make sure you can login to the Query Analyzer (ISQL) using NT
authentication
>before looking to the BDE for a problem.

>HTH,

>Jim

>Phil wrote:

>> I get 'Unknown user name or password' when trying to connect to a SQL
Server
>> 7.0 database using Delphi 4.0 with BDE version 5.01.  I can connect using
SA
>> as the user name but not when using my own ID.  I can connect to the
>> database using ISQl/W so it must be something with the BDE.  Any
information
>> about this problem would be greatly appreciated.

Other Threads