Board index » delphi » Float Fields in a linked table

Float Fields in a linked table

I have a master-detail relationship on a form.  The master record is
being looked up via a DBLookupComboBox.  Here's my problem, the text
field from the file are displayed in their linked TDBEdit fields, but my
float fields don't get displayed.  I can see their values in the
de{*word*81}, but the edit fields don't display the values.

Have I over looked some documented procedure for displaying float
fields.

 

Re:Float Fields in a linked table


Float fields work for me. What database are you using? Are you sure the
DataSource and DataField properties of the DBEdits for the float fields are
set correctly? Are you using a TTable or TQuery? What version of Delphi and
the BDE are you using?

--
Bill Todd (TeamB)
(Questions received via email cannot be answered.)

Re:Float Fields in a linked table


I'm using interbase.  I'm using Delphi 5 Professional and I just downloaded and
am installing BDE 5.11.  I'm using a ttable to retrieve and believe I have the
datasource and datafield set properly.  I am in the process of double checking
this form.  I also use this table on another form and it works properly, but in
that case the field is not protected.

I am working on this currently.  I appreciate your help and will re check my
form again.

Quote
"Bill Todd (TeamB)" wrote:
> Float fields work for me. What database are you using? Are you sure the
> DataSource and DataField properties of the DBEdits for the float fields are
> set correctly? Are you using a TTable or TQuery? What version of Delphi and
> the BDE are you using?

> --
> Bill Todd (TeamB)
> (Questions received via email cannot be answered.)

Re:Float Fields in a linked table


If I change my TDBEdit field to enabled = True then the fields display.  If I
disable the TDBEdit control it does not display, but my text fields will
display even though the TDBEdit controls are disabled.  I would like to disable
the field so that it can not get focus.  I know there are other ways, but I
would like to know which behavior is correct, to display the values or not?

Thank you for your time, I really appreciate the help.

Quote
"Bill Todd (TeamB)" wrote:
> Float fields work for me. What database are you using? Are you sure the
> DataSource and DataField properties of the DBEdits for the float fields are
> set correctly? Are you using a TTable or TQuery? What version of Delphi and
> the BDE are you using?

> --
> Bill Todd (TeamB)
> (Questions received via email cannot be answered.)

Re:Float Fields in a linked table


What version of Interbase are you using? Are you using the BDE dataset
components or are you using Interbase Express? What is the data type of the
field in the Interbase table? Is the DBEdit you are using the one that comes
with Delphi or is it a third party component? The value in a DBEdit
connected to a float field displays fine for me.

--
Bill Todd (TeamB)
(Questions received via email cannot be answered.)

Other Threads