Board index » cppbuilder » Delay Load causes linker to hang (ATTN Borland)

Delay Load causes linker to hang (ATTN Borland)

For months now I've been struggling with a project that keeps{*word*154} in the
linker after every few compiles. The only way out is to use task manager to
kill BCB and restart. Someone told me in response to a post I made to the
non-tech group that they had this same problem and fixed it by removing a
delay load DLL. Sure enough, this is the only project I have a delay load
DLL in. I just verified this is the cause of the problem with a quick test.
I removed the delay load DLL and compiled 6 times in a row with no{*word*154}.
Then I put the DLL back and compiled twice. The linker hung on the second
time.

    - Bill

--
----------------------------------------------------------------
Bill Zitomer
R.I. Soft Systems - http://www.risoftsystems.com
ScreenSaver.com - http://www.screensaver.com
Screen Greetings - http://www.screengreetings.com
Virus Myths - http://www.vmyths.com

 

Re:Delay Load causes linker to hang (ATTN Borland)


Thanks for this, I've had this linker problem for a long time, but haven't
heard about it being related to the delay loading of a dll.  I've removed
the DLL from the delay load list and hopefully it will go away :)

Thanks

Russell

Quote
"Bill Zitomer" <bzito...@risoftsystems.com> wrote in message

news:3ab8b59e$1_1@dnews...
Quote
> For months now I've been struggling with a project that keeps{*word*154} in
the
> linker after every few compiles. The only way out is to use task manager
to
> kill BCB and restart. Someone told me in response to a post I made to the
> non-tech group that they had this same problem and fixed it by removing a
> delay load DLL. Sure enough, this is the only project I have a delay load
> DLL in. I just verified this is the cause of the problem with a quick
test.
> I removed the delay load DLL and compiled 6 times in a row with no
{*word*154}.
> Then I put the DLL back and compiled twice. The linker hung on the second
> time.

>     - Bill

Re:Delay Load causes linker to hang (ATTN Borland)


i was delay loading the odbc32.dll for a while and then i read a similar
message.  The linker had been{*word*154} on me every few times.  i removed the
delay load and haven't had a linker hang on that project (or any others) for
a week or two now.

There is definitely some sort of problem there.

--matt

Quote
"Bill Zitomer" <bzito...@risoftsystems.com> wrote in message

news:3ab8b59e$1_1@dnews...
Quote
> For months now I've been struggling with a project that keeps{*word*154} in
the
> linker after every few compiles. The only way out is to use task manager
to
> kill BCB and restart. Someone told me in response to a post I made to the
> non-tech group that they had this same problem and fixed it by removing a
> delay load DLL. Sure enough, this is the only project I have a delay load
> DLL in. I just verified this is the cause of the problem with a quick
test.
> I removed the delay load DLL and compiled 6 times in a row with no

hanging.

Other Threads